Strange "Not Ready" Behavior with New NEJE 3 Max

I recently built an NEJE 3 Max kit and extended the “y” axis rails to 1016mm. After setting up the new machine in LB, I found that carriage moves, cutting projects, etc. worked fine but the machine would often not come back to “Ready” status in the Laser window after any given operation. To get back to “Ready” I had to disconnect the machine by right clicking the Devices button in the Laser window so the USB connection would drop and reconnect (but this didn’t always work either.) Another way was to power down the NEJE machine, wait a few seconds, then power back on. This didn’t always work either and the problem became quite annoying. I have another “home built” laser cutter that has a fan to cool the stepper motor driver chips. To keep the fan from spinning via USB power even when that machine was turned off, I had installed an inline rocker switch (purchased through Amazon) which permanently turned off the 5 volt USB power but allow data to still flow (be advised that most of the switches sold on AM cut off USB power and data, which won’t work for this application). I couldn’t find another “data only” switch like this for the NEJE 3 Max so had it plugged directly to the computer’s USB port and power was going to its controller even when the machine was powered off. I tried the switch from the other laser cutter and my problem disappeared. Since I couldn’t find another switch, I ordered some USB “A” connectors and rebuilt two cables (one for each cutter), without connecting the +5 volt line. Now the new NEJE cutter works flawlessly and I have a spare inline switch. It’s too bad you can’t find “data only” USB cables on the internet. It’s a feature needed on many 3D printers as well.

Fantastic discovery! Congrats! I’m tagging this post as solution because it won’t let me tag the first post - but the credit goes to you.

I am literally having the same issues…. Exactly as you described in terms of having to disconnect and/or power down to get the lightburn to recognize the port as not busy.

My fox alien Reizer mega never has this problem. Only the neje 3 max. I suggest they make some data only switches or cables and include with machine and make them available to us as well. I was about ready to ditch what otherwise seemed to be a great machine

Can you provide what you did to make the data only cables?

I’m not familiar with the solution but if it’s literally just a matter of preventing powered USB you could try taping or removing pin 1 from this diagram. That’s the pin that provides +5V. This is looking down the end of a USB-A connector.

I do something like this for other reasons. A simple solution is to simply use a thin strip of tape (really anything that would serve as electrical insulation) to mask off the pin. This will prevent the controller from being powered through USB and will need to rely on the power supply for power.

PY’s solution using a narrow piece of tape is probably the easiest. Since I have a strong electronics background, I cut off the “A” cable end, soldered the “-”, “D+” and “D-” wires to the new “A” connector and cut off the “+” wire. In effect, a data only cable. This seems to be a peculiarity of the NEJE 3 MAX v1.0 board. I also ditched the laser head and installed an OX-Laser 5.5 watt head as it allows me to focus from a higher point (I had to design and 3D print a new laser mounting plate for the new “head”)

I love being able to cut items up to 30" x 40" too!