Stray line on passes

Hoping someone might have a suggestion or know if there is a setting in LB to help with the problem that is occurring; I am getting a stray offset/stray lines at random on cut shapes. I am just trying to cut vector lines I’ve drawn in Lightburn. It usually happens on rectangles on the second or third pass (4 passes total), not exactly sure how to explain it - so I’ve attached photos The laser set up is a Openbuilds Acro 1010 (30"x30" cut area) - Blackbox motion control, 24V PSU with a Ortur LU2-4 module. I’ve tightened and checked all belts, made sure there was no areas for my drag chains to catch to hold up or shift the laser module. Its all moving smoothly. I tried cutting series of squares to pinpoint if its a spot my x-axis is getting caught/shifting, but its happening at random. I’ve tried voltage adjustments for my Nema 17 motors which helped slightly, it made it less drastic; but it continues to happen.
If anyone has any ideas on what could be causing it or suggestions, that would be greatly appreciated. Thanks

Are the passes done manually one after another or within one job where you’ve specified the number of passes in the cut layer?

Is the shift always on the X axis?

Do you have any observations at the time the shift occurs? Any sounds or other changes at the time of shift?

The passes are specified in the cut layer - the paper is also attached to the base table so no shift there.
Only on the X axis.
No sounds, nothing I can see that shows a shift. I don’t see a change in speed or struggling; It looks like the X axis just travels further on one or two of the passes.

I was considering the possibility that steps were lost during motor power down but that’s not going to be the case if these are during the same job.

These types of things are almost always going to be mechanical so best to start there. You’ve indicated already checking belt tension but you may want to revisit that. Check that there is no slack on either side of the motor pulley. Additionally, I’m not familiar with your particular machine but is it possible that something is out of alignment that would allow for belt slipping even with proper tensioning?

If belt tension is good then I suspect this may be from backlash, specifically that your pulley on the X stepper is not firmly secured to the stepper shaft. This would be fairly consistent normally though. If you can feel any slop as you turn the pulley CW and CCW then this is the likely source of the problem. Make sure that the grub screw in the pulley is secured against the flat portion of the stepper shaft. There should be another location on the pulley for another screw. Make sure that is also secured. It’s possible that the grub screws are double stacked so watch out for that. You’ll need to secure the inner one before securing the outer one in that case. Use a thread locker if you have it.

You could run a test for this if you wanted… a horizontal line test done bi-directionally at a slow speed. If the ends don’t align it could be from backlash.

1 Like

Well, you were exactly right on what was going on. I took a closer look at the X axis and the gantry, the wheels were not tight enough along the rail which allowed some minor movement. I checked on the belts again, then saw the timing pulley was not only out of line with my wheels, but it was slipping on the shaft of the motor due to the grub screw not being tight enough against the flat portion - just like you suggested. I took it apart and I followed your advice; it is now working better than ever. Thank you very, very much for your time and help, I really appreciate it.


Awesome to hear. Glad it was fairly straightforward and that you’re in business.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.