Stretched Flat Image (Not using Rotary)

Hi, I’m new to laser engraving and to LB. I got a Vigotec L3 laser and for some reason when I engrave either text or image everything is stretched out. the Image i have on the screen is not the same with the actual image printed. I tried looking for answers here in the forums but so far all i read pertains to the rotary function which i am not doing. I tried disabling the rotary button but the results are still the same.

I need help! Thanks!!

Thanks for posting, we can offer some suggestions. But we are needing a bit more information to help steer you in the right direction.

What motion controller and firmware is used to drive this laser? Share images of what you are wanting to produce, how it looks in LightBurn, including the ‘Preview’ window, how you have that job set, and the results you got.

Let’s start with this, and we can go from there.

Hi Thanks for the quick response! Bare with me, not sure if this is the right answer :smiley: motion controller i think is GRBL, not sure of the firmware though… This is the sample image i tried to do

this is the result:

Click on the ‘Console’ tab, then type $$ and hit Enter / Return. You will see that window spit back a bunch of information. Please copy and paste the results here for review. That window scrolls so make sure you copy it all before pasting here.

$0=10

$1=25

$2=3

$3=2

$4=0

$5=0

$6=0

$10=1

$11=1.000

$12=0.002

$13=0

$20=0

$21=0

$22=0

$23=0

$24=25.000

$25=500.000

$26=250

$27=1.000

$30=1000

$31=0

$32=0

$100=80.000

$101=40.000

$102=250.000

$110=8000.000

$111=8000.000

$112=500.000

$120=500.000

$121=500.000

$122=10.000

$130=500.000

$131=500.000

$132=200.000

ok

I see issues with how this firmware is currently set. Is this the firmware provided with this laser or have you updated it?

Here is the official documentation for Grbl 1.1. This is a good resource and should be understood when adjusting these settings.

$32 - Laser mode, boolean

When enabled, Grbl will move continuously through consecutive G1 , G2 , or G3 motion commands when programmed with a S spindle speed (laser power). The spindle PWM pin will be updated instantaneously through each motion without stopping. Please read the GRBL laser documentation and your laser device documentation prior to using this mode. Lasers are very dangerous. They can instantly damage your vision permanently and cause fires. Grbl does not assume any responsibility for any issues the firmware may cause, as defined by its GPL license.

When disabled, Grbl will operate as it always has, stopping motion with every S spindle speed command. This is the default operation of a milling machine to allow a pause to let the spindle change speeds.

$100, $101 and $102 – [X,Y,Z] steps/mm

Grbl needs to know how far each step will take the tool in reality. To calculate steps/mm for an axis of your machine you need to know:

The mm traveled per revolution of your stepper motor. This is dependent on your belt drive gears or lead screw pitch.
The full steps per revolution of your steppers (typically 200)
The microsteps per step of your controller (typically 1, 2, 4, 8, or 16). Tip: Using high microstep values (e.g., 16) can reduce your stepper motor torque, so use the lowest that gives you the desired axis resolution and comfortable running properties.

The steps/mm can then be calculated like this: steps_per_mm = (steps_per_revolution*microsteps)/mm_per_rev

Compute this value for every axis and write these settings to Grbl.

$100=250.000 X steps/mm
$101=250.000 Y steps/mm
$102=250.000 Z steps/mm

Start by setting $101=80 That will most likely fix you up as generally these types of lasers use a value of 80 for both the x and y axis’s

Yep that did it! Ratio is now normal! Thank you both!!!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.