Stretching in Y axis on rotary

My Y axis is way, way off. In LB it shows 2" height which on rotary (would be the circumference) and it measured out to 4.875 when the file was run.

Rotary is Mansfield, 4100 steps/revolution, wheel diameter measured (was not the 35mm). Machine shut off after file changes and after rotary changes. When I do the “test” on the rotary setup the item rotates 1" less than a full turn and returns to the same zero.

So, what am I doing wrong. Any kind of formula to correct for this so I am not having to do multiple tests for “width” of the item printed on the rotary? To get the 2" I had to squeeze the height way down but the rotary wheel diameter was not correct at that time (which is how I discovered the diameter different that advertised). And now with correct settings it is still the same.

Thanks folks.

Hi Jack, have you checked your ‘machine settings’?
top of Lightburn, ‘Edit’ ‘Machine settings’ somewhere near the bottom are the rotary adjustments.

LOL I forgot to load the photos.
I have only used the edit machine settings to turn off the rotary after use as it gets left over after going back to regular. Are there settings there I should change?

I don’t have a rotary but have seen the settings for them, pulse,rotation, steps etc…
Could check to see if they match yours.
I’m sure someone with a rotary will be along soon.

That is what I show in the first photo, that writes to that section of the program.

That’s totally different to the settings on mine.
Ok now i see :+1:

Have checked this out?

Yes I have seen this in the past, but got some reminders to give it another shot.

WOW did I learn a lot figuring this out.

  1. It is mandatory to set the rotary # turns for each diameter. It changes with the diameter.
  2. To set the # turns and get it right you MUST not use the test function on the setup page. It sets way, way too many turns per rotation, if you can get it perfect.)
  3. You must use the “move” function as in the above video. (IF you go back and try the ‘test’ function in the setup screen it will only move 1/4 turn.

Once set correctly the width and length measurements equal the screen dimensions. The part that amazed me the most is that from circumference to circumference you had to reset the #turns, I would have assumed that to not change. That is what I get for assuming. And Kris…thanks for reminding me of this video.

He’s actually incorrect in the video - the test button in the software should spin the ROLLER once, not the object. If he had put the tape mark on the roller itself, the test button would likely have worked with his 4200 steps.

You do not need to change the “number of turns” anywhere - the software does that automatically when you use the correct setup process and step counts.

Well it cured my stretch by doing it the way I described. If I use the test button it changes from diameter to diameter how far it is off on the full turn, back to start point. It never would come in at 11.5, if I got the full turn, it did not return to the start point. Best I could get was almost (1/4" shy) of full turn and 2mm over on return to start. This changed from one diameter to the next also. .

So if it is wrong and fixed my stretch what do I do here?I was doing the object will try again with the roller method as per

Oz, you are very correct, (of course). If I follow that process in the above link I posted, it all works, does not stretch in any Axis, engraves the size I expect. Please accept my apologies for the incorrect information above. I must say what I did was use the numbers off the rotary and they are no good. The wheels are not 35mm, they are 36 with the turns per rotation at 2000, so it was far off and no wonder I was having trouble.

I’ve been wrong before (really, it happens) so I’m not one to take offense when challenged, and I’m glad you got things working properly. When it’s set up correctly there’s much less fussing with it involved, though it can be a genuine pain in the backside to get it set up the first time. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.