Struggling with Ethernet connection

When I first set up my laser (MF1220-50) I tried both the USB and ethernet connections. I had an old D-Link Wi-Fi router with a 4-port wired switch. The laser lives in the garage, so I ran a CAT5 ethernet cable from an 8-port switch in the house (which was connected to the main Wi-Fi router/modem). The D-Link 4 port switch provided a network connection to the laser, the garage PC (a Windows 10 Mini PC) and a wired web cam. At first everything worked. The PC had internet access and could also control the laser through the ethernet cable. I also tested the ethernet setup from my office PC, which is on the same network, and that also worked.

From that point on I just used the USB connection because that’s what I was used to with my diode laser. I recently started seeing a lot of posts on this forum recommending that ethernet was the best way to go, but when I selected the Ruida Ethernet profile I’d set up months ago, it would no longer connect. The info in the Ruida manual for the 6442 is sparce, I read every post about ethernet on this forum, to no avail. Thinking it might be the D-Link router/switch, I swapped it out for the 8-port switch (some of the ports had stopped working after a storm so I replaced the 8-port switch with a 10-port switch).

I went through the process of adding a new device, gave the laser a new (unused) IP address and tried a few different Gateway addresses based on suggestions on this forum. I finally ended up with 192.XXX.X.125 as the IP address and used the Mini PC’s IP address as the Gateway address. Turned everything off and back on and it started working. Both computers could once again control the laser. Two days later the 8-port switch completely died, so I replaced it with a new one. Now I’m back to where I was a week ago, everything has network access (I am able to ping everything from everywhere), I just can’t control the laser over the ethernet anymore.

I didn’t change any of the settings, I just plugged in a different but similar (unmanaged) ethernet switch. So, I’ve gone from it worked, it didn’t work, it works, now it doesn’t work again. I’m at a loss, I understand the need for a unique IP address but there isn’t much info about what the Gateway should be. Any advice would be appreciated.

A few things to unpack:

  1. the switch you have now, is it just a dedicated switch or is it also a wifi router? If you’re familiar enough, can you describe the network topology of the in-house router/switch to the garage switch?
  2. if you plug a computer into the switch, does the computer get assigned an IP address automatically? If so, what is an example IP for the assigned computer?
  3. If your Ruida is on the same subnet as the other devices on your network then the gateway address should be shared between them. This is typically the router address. If you were to be only communicating between computer and controller then I’ve had luck with having the gateway on the controller point to the IP of the computer.
  4. Since the controller expects a static IP, you’ll want to reserve that IP in your router/DHCP server assuming the devices are on the same network. Or else, if your DHCP server only gives out addresses of a specific range then choose an IP not in that range.

@berainlb has covered most of the issues…

Do you have something on windows that will allow you to scan your network?

I use ‘arp-scan’ on Ubuntu Linux, and I think it or something similar is available for windows…

You should be able to ‘see’ the laser ‘hanging’ out on your local network. It will also tell you it’s address…

Pay attention to @berainlb comment point 4.

Mine goes through a Pi 4 right now, but it was used as a direct connect to the pc in the garage and via a t-link wifi bridge…

Keep in mind that the Ruida uses udp/ip not tcp/ip… Udp (user datagram protocol) is much faster than tcp/ip, but has no error reporting and makes no attempt to confirm a connection before transmitting or receiving.

The lightburn pi bridge has software to help with is issue…

I can send a file from the work computer and go control it from another computer… it’s pretty dumb…

Good luck


What was the solution?


I tried to select both of your responses as “Solution”, but it will only let me pick one. Using the insights you both provided, I was able to discover what had happened. I use a couple of wi-fi enabled devices in my workshop, a wi-fi switch to turn on the shop lights, and a wi-fi outlet to turn on the chiller (this is the one that bit me). After I had the ethernet connection to the laser working (last week), the wi-fi outlet went off-line and needed a factory reset. The laser was not on at the time, and for some reason the router reassigned the IP address I had been using for the laser to the wi-fi outlet. So, every time I pinged the lasers address, I got a response, not realizing it was actually the outlet. Using Arp scannet and my ISP’s mobile app, I began the process of identifying what each IP address was assigned to (I have 33 wired and wireless devices on the network as a whole). That’s when I discovered that the outlet was using I changed the laser to an IP address halfway between the outlet and the workshop PC, and the ethernet connection to the laser is working once again. “Pay attention to @berainlb comment point 4” is exactly what I need to do. I have to figure out a way to prevent this from happening again, to “reserve” this IP address for the laser so that it doesn’t get reassigned again. I’m including a rudimentary diagram of my network, the modem and wi-fi router are provided by my ISP.

If you make note of the different device MAC addresses, it may make sorting out any future IP# changes.
There are free LAN scanners that include the MAC addresses so it makes it easier to find a device.

I can bind my ip to the mac address on my router.

The other options is to restrict the ip range and put it in that range so the router won’t change it’s address…


I assume DHCP is handled by the WiFi Router/Switch. There may be a way to apply static DHCP reservations based on MAC address. You can use this to reserve an IP for the Ruida even if the RUIDA doesn’t use DHCP for IP assignment. If your router does not support IP reservation it should minimally have a mechanism to define IP range for DHCP. It may already be limited so take note of the IP range that’s not available to DHCP and use one of those addresses for the RUIDA. You may want to create a list of these so you can recall them.

If the DHCP range covers the entire subnet then simply reduce the range so that you do have IPs that you can assign manually.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.