Suggestion for 1.1f config.h edit, homing issue

Hi There!
I have a up and working DIY laser that uses a Woodpecker camxtool V3.4 3 axis GRBL 1.1f controller with a Atmel ATMEGA328P. I installed limit switches and they work as limits, but I get no movement when I ask the machine to home. Then after some time of no machine movement it goes into homing alarm. So I did a bunch of reading and came to the conclusion that the preloaded info on the controller is telling the Z axis to move first. I don’t have a Z axis to find!
So I did some more reading and It appears that I need to update my Configuration.h file to comment out Z home and comment in X and Y only. Or can this be done from lightburn? I have Z axis disabled in the lightburn settings!!

Now my question is can I get the .h file off of the controller or do I need to find a file on the net, edit it, compile it and upload it? If so I guess I need to install an Arduino IDE?
Now the big question, what files do I pick from the net? I’m guessing it has to be one for GRBL1.1f? Is it posable that if I install a new file that it might be missing some of the features that the original file might have?
I guess there is no turning back, without access to the original file installed by the manufacture of the controller?

Here are my settings:

$0=10 $1=25 $2=0 $3=2 $4=0 $5=0 $6=0 $10=1 $11=0.010 $12=0.002 $13=0 $20=0 $21=1 $22=1 $23=0 $24=25.000 $25=500.000 $26=250 $27=3.000 $30=1000 $31=0 $32=0 $100=800.000 $101=800.000 $102=800.000 $110=1000.000 $111=1000.000 $112=600.000 $120=30.000 $121=30.000 $122=30.000 $130=200.000 $131=200.000 $132=200.000 My controller ![woodpecker2|374x500](upload://n4GVGVR3xmfm3ykjFFMfuAKn3dP.jpeg) Thanks Glen

Odd the settings are not coming out in single file and the attached photo is not showing. it’s all garbled together?

$0=10 $1=25 $2=0 $3=2 $4=0 $5=0 $6=0 $10=1 $11=0.010 $12=0.002 $13=0 $20=0 $21=1 $22=1 $23=0 $24=25.000 $25=500.000 $26=250 $27=3.000 $30=1000 $31=0 $32=0 $100=800.000 $101=800.000 $102=800.000 $110=1000.000 $111=1000.000 $112=600.000 $120=30.000 $121=30.000 $122=30.000 $130=200.000 $131=200.000 $132=200.000 ok

I have been playing some more. I found an UNO that was sitting around and figured I’d practice sending files to the UNO and not my Controller for now. So I upload the GRBL 1.1f to the UNO. It uploaded and appears to be functioning in lightburn. I’m assuming its working I don’t have a CNC shield for the UNO. but I can talk to it with Lightburn get info $$……

So now I have a new question!
Can I just send a edited Config.h to the controller or do I need to send everything from the GRBL file in the Arduino library on my laptop to the controller? I’m assuming the .h stands for HEX file???



.h is C++ programming notation for header file. Source files usually get a .cpp suffix. No, you can’t send that to the controller, it needs to be compiled.

And you can just send ‘any’ program compatible with the 328p and it will run. But it won’t run your CNC.

You need to plan your layout - in particular, your pinout, how you use the pins, your steppers, etc.

This is the info you need:

This is the homing-specific section:

I’m more of a smoothie than grbl guy, so I can’t say categorically whether you can $ command your way to changing the homing order, but the info is in there.

Hi Bonjour,
Thanks for taking the time to respond!
Thanks for the links, good info, just looked at it and have read it several times in the past week or two. The instruction section for the homing says to make changes to the configuration .h . But doesn’t give any info on what to do with it once edited :frowning:

So I’m still reading and learning, but still not 100% sure of how to get an edited copy of the modified configuration.h file onto the controler. If I just update the config.h file then that should not effect my pinout. stepper info…
It would be nice if one could pull the file off of the controller edit it and put that one file back on it.


You change the .h file, then recompile grbl using Arduino IDE.

Thanks again for the link!
Yes that is the exact video and website instructions that I used to load the GRBL 1.1f on the new Arduino yesterday and it worked well.

So I think I going to bit the bullet and try to upload it to the Woodpecker controller! I have two of the controllers so if I mess one up I still have the working one that is on my laser machine.
The woodpecker has the 380 p on it.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.