SVG Import scaling issue

Hello,
Been using imported SVG’s in my workflow without issue(Never had to re-scale anything). I’m now trying to use SVG’s exported from Shapr3d on an ipad pro. I’m encountering a scaling up issue where the SVG’s are scaled up in size by a factor of 1.333. This seems to correspond to a difference in dpi (72 vs 96). I have attempted to compensate in Lightburn by changing the SVG import dpi setting but it does not appear to have any effect on the scaling. The svg’s come in oversize no matter what the import svg dpi setting is.
I’m working with the folks over at Shapr3d to try to deal with the dpi issue but I just wanted to check here about any thoughts as to why the svg dpi import setting does not seem to have any effect.
I get the feeling that Shapr3d export spec lacks some information that LB depends on for this feature to work.
Any feedback would be greatly appreciated.
Regards,
Kevin

Not an elegant fix - select all

With ratio locked, key in 75 in one of the percentage boxes

Hit Tab key

Standard SVGs use actual units, like mm, inches, etc. If software writes an SVG with no units, or just pixels, then the actual interpretation of those units is not defined, but usually in “display units”. InkScape and most other software exports in 96 DPI units, and Adobe Illustrator exports at 72 DPI, causing no end of confusion.

There’s a setting in Edit > Settings, in the File Settings page in LightBurn to switch between 72 and 96 DPI SVG imports.

Thank you RalphU for your suggestion.
The point I was trying to make is in an effort to try and avoid re-scaling every file I import, I tried the SVG dpi settings in Lightburn to compensate with no success. In other words, the dpi adjustments does not work in this particular case. So I was seeking some advice as to why the setting in lightburn doesn’t help me in this case.
Thank you again for your workaround.
Regards,
Kevin

Thank you Oz.

The DPI setting for SVG importing does not seem to make any difference (In this case). Import at 72 dpi and I have to scale it down 75%. Clear the file change the setting to 96 dpi and import again and I still have to scale it down 75%. Perhaps it only takes effect if I restart the application? Or perhaps it doesn’t work if the file doesn’t have the necessary meta data to describe the actual units? When I’m back on that machine, I can export out a simple square from Shapr3d to demonstrate what I’m seeing if you are interested.
Regards,
Kevin
SQ10x10SVGImport.lbrn (4.7 KB)

PS. I’ve attached an example lightburn file where I imported a SVG file of a 10mm x 10mm square. I was unable to upload the SVG file.
OS = OSX 10.15.7
Lightburn = 1.0.0.1

If you can attach the SVG I can have a look at the source info. The LightBurn file won’t tell me anything. You can either rename it to .txt, or just email it to support@lightburnsoftware.com and include a link to this thread.