Tab Generation Bug?

I have little bit different problem and I think it’s a bug:
Let’s assume I have 2 squares and generate 2 tabs for each of them (automatic):

I press OK, and then I want improve them a bit (I WANT, but I DIDN’T - so they stay at places they have been generated), so I go to layer options again and change tabs to manual. They stays on palce as they were generated:

I press OK.
Now I made a new one square. So I go to layer options again, and switch to automatic again.

Press OK, tabs were regenerated. But they didn’t. If I go back to layer and check “manual”, see what happens:

The last object has no tabs. So I go to layer options again, switch to automatic, change the number of tabs to 4 per object and switch to manual:

So I push “clear tabs”, change to automatic, (now there are 4 tabs per object), press OK and going to layer settings again (there are still 4 tabs per object), change to manual and:

Boom! tabs disappeared and I can’t modify them.
So there are two options:
1/ there’s some misstake at first generation, that it’s coincidently inherited from automatic creation and it should NOT be
2/ there’s another misstake, that tabs are not regenerated correctly.

@LightBurn is it clear? can you reproduce it? is it a bug or a feature?

Moved to a new topic. It’s always best to start a new topic unless your issue is identical.

I’m looking into this… I think it’s as intended, but I want to run through what you did a couple times and either confirm or be able to explain why it works the way it does better.

Maybe it is identicall. because @Squideatingdough wrote about deleting 50%, grouping etc… it can be very similar, because it’s some unexpected behavior at tabs generation. But, of course, better fork it here, have no problem with this. Thank you.

Are you sure you are clicking on ok and leaving the cut settings window before going back and changing to manual from automatic?
If you enable tabs, select automatic, then select manual without clicking on OK first and then going back into Cut Settings the tabs will just disappear. Because when you click on manual it will not convert the tabs that were just being displayed while in automatic mode, it will convert the tabs that were already present on the shape before you opened the cut settings. If it didn’t already have tabs before, then you won’t see any. Hopefully that made sense.
My point is that what you see while Cut Settings is open is only a preview. Until it’s committed by clicking ok your shapes don’t actually have any tabs.

What version of LightBurn are you using and on what operating system?
I’ve tried to replicate what you are seeing, by following your steps exactly and it works as I would expect every time. So it’s hard to say what it could be.

I’m using 0.9.19 on Linux (Linux Mint based on debian buster/sid)
I’m pretty sure what I’m doing :wink: Pressing OK was part of plan. I wanted to know, when tabs are generated.
I’m trying the same again and now when I switch from manual to automatic, some dialogue window appears, which tells me that “You already have manually placed tabs. Switching to automatic will remove them. Are you sure?” - this didn’t happen. It’s quite unpredictable behavior. But when I check OK, automatic tabs make me tabs at the new object and when I click back to the manual (which should be "automatically removed, as the dialogue told me), there are missing tabs at the last object again. So they were NOT removed, or were? Because it looks still the same as before. This happens just by clicking automatic/manual, without confirmation (OK button).

Not doubting, just confirming.

What didn’t happen?

If you had automatic tabs and switched them to manual, clicked OK, reloaded cut settings, then clicked on Automatic - without manually changing the position of the tabs - then the now automatic tabs will be in the exact same position. Just they’ll now be green.
If you have tabs that are manual the system has no way of knowing that their placements are the same as automatic - so it will always show you that removal confirmation when changing from manual to automatic and you already have existing manual tabs on that cut layer.

This confirmation dialogue. I’ve seen it right now first time.
Strange. Maybe there’s some situation, which goes another validation way? Don’t know…

So - in the situation, when I don’t touch “manual” (red) tabs, then “The confirmation dialogue” will ALWAYS apper, when I switch to automatic? First time (when I wrote this topic) I didn’t see ANY confirmation, all of the red tabs were changed to green and at teh new object appeared NEW GREEN ones. After switching back from Automatic to Manual, these NEW green tabs (on the NEW object) disappeared. I was expecting that if I change Automatic to Manual, ALL tabs will be converted - including the new ones. And this doesn’t happen.

So, yes, that dialog will show up for the confirmation if you already had at least 1 manual tab on any shape in the cut layer before you opened the cut settings edit window. It will not appear if the state of the tabs on shapes in that layer was anything else before you opened cut settings.

This is as expected. It will only convert tabs that actually existed before you opened cut settings. What you are seeing while that dialog is open is just a preview.

So it’s not possible to “pre-generate” tabs by automatic method, and then just re-arange them? And if yes, so WHY the first generation makes template for manual tabs? (these, which are converted from green to red)
So when I change the count of tabs per object, I’d expect that LB will count these “automatic” and offer them for manual correction… Anyway it’s probably not error, but it’s quite strange.

[edit: Of course, in case you didn’t move these tabs manually before]

You can - automatically generate the tabs. Then go into the “Add Tabs” tool on the tool bar, select a shape, and move the tabs around - or add a new one - or delete one. They will become manual tabs at that point.

Not sure what you mean by “offer them for manual correction”

I mean that “automatic” makes you some “template” which you can convert to “manual” tabs and then move them or rearrange them. As it’s done with “first-time” automatic generation of tabs. (THAT is the confusing behavior - why the first time “automatic” became “manual” and then - after adding next objects - not?). Anyway, if you think it’s OK then we can close this discussion - it’s becoming to be more about philosophically correct behavior than about some potential bug.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.