Testing Lightburn has my laser stuck in M3

Hi, I purchased a SculpFun S9 and worked great until I tested LightBurn. Now its stuck in M3 mode.

Switching back to LaserGRBL hasn’t helped. Your software is an option for me later. Its just too much starting out. Simplifiy that window some.

From the short hour I was looking at the software, I connected to my machine without issue. It moved the head around with jog, I set a few positions. I never tried to use it because I couldn’t figure out how to engrave without making several changes to power and speed for many colors. Probably an oversite on my part and a lack of knowledge. I went back LaserGRBL because it was Simple and Easy to use performing most of the task an engraver needs without all the Extra.

Now that I am back to LaserGRBL, the laser itself will now not modulate power. I have check the settings and I am setting things correctly. I use M4 with 1-bit Dithering for greyscale. Same as I was using before LightBurn locked my laser into M3.

I am asking for help because it worked fine before the install of LightBurn. I have had it for two weeks, used it about 20 hours. Its pretty much useless to me just for cutting. I have also contacted SculpFun for their input.

Bottom line is I had a working laser until I used your software. Please help.

Without being a programmer, however, I know from personal experience that LightBurn can not change a machine setup. All permanent changes in the setup must be written to the controller, (this applies to G-code machines and also DSP controller), manually by the operator. If you have e.g. installed a new firmware to be able to use certain features of a particular program, or modified and customized your machine to work properly with another program, then you need to go bake to the starting point with either a backup or by manually resetting the values ​​as needed.

Thanks for the response. I also agreed that I had very serious doubts that it was software related. It was just so confusing as to what was wrong.

But happy to say I have solved the issue, but am still a little confused as to why this solved it. When I first started using my laser it connected through com port 3. Apparently, SculpFun doesn’t like it when you unplug it from one port overnight and use a different port the next day. Reconnecting to the original port seems to have solved the power modulation issue.

Again Thanks for the help,

It’s good to hear you can get on with your machine. Maybe at a later date you want to try LightBurn again, it is after all the best laser program on the market, in the eyes of many.

Oh, I haven’t abandoned LightBurn at all. Please don’t misunderstand. I am aware that it is far superior. It’s just a bit much starting out.

I plan on purchasing another laser next week and had gave thought into an xTool or an Atomstack. The reviews on the xTool seem to be positive in the hobby class.

I haven’t looked at the AtomStack but briefly. Any thoughts or input on a second laser to use with LightBurn, as I learn LightBurn? I would like to keep the SculpFun running in the process.

Any reason why you’re looking at xTool and Atomstack when you already have the Sculpfun? I would consider all those in the same class of laser. Certainly some differences in characteristics but nothing game changing. If you need to increase the number of lasers because you need to burn simultaneously that’s a different matter.

A couple of inputs for you to consider. While the xTool D1 seems like a very well sorted laser hardware wise it still seems half-baked for use in LightBurn. Some folks are getting acceptable results for their needs but firmware issues make it impossible right now for certain types of engraving. Check this forum for some insight on that. xTool seems serious about improving the product so hopefully they get all their issues sorted.

One commonality I’m seeing in all your laser choices is that all 3 of those manufacturers prevent writing to EEPROM. So if you need to make any configuration changes that’s basically not an option with those lasers. This is one of the reasons why xTool D1 isn’t able to be tuned to fix some of their issues. I believe Atomstack may permit changes to occur for the current session but don’t persist those changes after a power cycle. I don’t recall Sculpfun’s behavior.

Just something to consider as you’re exploring.

The biggest reason for looking at other options is support. Several e-mails to SculpFun without any responses.

In my non-scientific observations of support quality for this class of laser product looks something like this. I’d be curious on others’ opinions.

Ortur - they have some problems with their units like everyone else but from what I’ve seen they’re very active about dealing with these problems and have relatively good web support. The fact that you can even get updated firmware and current information from their site says something.

2nd tier:
Neje - Their web presence has improved and firmware readily available although they don’t seem to be as responsive with individual issues. They seem to be pretty serious about improving their support from what I’ve seen.

xTool - they’ve been open about their challenges and have good documentation online. Seem to be a professional company but haven’t yet addressed some of the problems with their GRBL implementation.

Atomstack and Sculpfun fit here. They have some interesting products but I haven’t heard any positives about their support. Online information is relatively scarce. I suspect one of their reasons for locking out their EEPROM is in hopes of reducing support calls although in some ways it could end up causing more. Atomstack, to their credit, seems to be ramping up their efforts but I fear they’re spending more money on marketing than their support. I don’t think I’ve ever seen an on-line firmware for either of these companies.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.