Text reversed and 2 devices setup 1 laser

Hi Everyone.

I am trying to sort out lightburn to a new machine, K40 and I am having an issue, firstly I run 2 computers, design station macbook pro and machine controller windows 10.

The problem I thought was I design on the Mac, transferring Lightburn file over to Win 10 machine went to print and my file was reversed and upside down and that I thought had something to do with the two computers not being the same.

Both machines are to the best of my knowledge set up exactly the same, I put them side by side and checked and as far as i can see the screens/settings mirror each other apart from the odd difference in win/mac software versions, both on latest version of lightburn.

Ran a quick test by typing 12345 from the Windows machine in Lightburn, which is the K40 controller and this reversed the text and turned it upside down picture attached.

Screenshot of windows machine attached as well showing settings and original design.

I thought the origins had to be the same on both machines but I am not sure now as the windows machine did not print the windows created design correctly.

Would this just be a matter of getting the origin correct on the windows machine which i assume this error is and then just making sure my Mac mirrors this so any designs I send to it will print ok.

I seem to be banging my head against a brick wall at the moment with this so I have stopped and I thought to ask the community to de-stress!

The idea is that i design on my mac, network the file over and just use the windows machine to print and I thought that was ok until today.

Thank you

Macbook Pro Mojave, K40 Laser, Kingbase Smoothieware Controller , Windows 10 on bootcamped mac mini as machine host, Lightburn latest version.

The configuration in the Smoothie board will affect where zero is. In your case, you probably have it set up so zero is where the switches are. You can either change the config file to offset the zero point away from the switches, to match the origin in LightBurn, or you could move the LightBurn origin to the rear-left corner. Either should fix it.

1 Like

Thanks Oz I will take a look at the configuration file I finally managed yesterday to get the laser going by altering the origin again and it worked but its best I think if I do the config file.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.