Text "type" automatically sets to Date/Time. Not good for basic text engraving

LightBurn 0.9.07
Ruida Controller through ethernet
Win10 64bit

Edit
I shouldn’t have referenced this as an error. It’s not. I did a poor job of explaining my real issue. The problem was that I didn’t intend to use this awesome feature, and wasn’t expecting it to automatically place itself into my simple engrave job. The Date/Time mode was set at the time of text creation by the software. I wasn’t expecting that. Thankfully I noticed it in preview before ruining material.
End Edit

I ran across what I’m perceiving as a preview error. Looking at the screenshot, there is text for business hours that was added for a “fill” operation. When previewing the text you can see that those two columns are all jumbled up.

I checked the text “type”, and both were set automatically to “date/time”. I set them back to normal, and the preview went back to normal.

I haven’t tested any other conditions such as, does it also happen if the layer is set to line, does font style matter, etc. I’m just mentioning it as a potential bug. In my case it was an undesirable effect of a beneficial feature that I’m not currently using. It was also easily fixed in my particular situation, but I can see where this might be a hassle if you needed to retain the text type. My intention was only to use the preview to get sign off from a customer.

Thanks for listening.

It’s not a bug - it’s interpreting your characters as date/time insertion formatters. s is for seconds, d is for ‘day of the week’, and a is for ‘am or pm’, so sunday became 33(secs) + un + 6(day) + am + y. This is working exactly as designed. Read here: https://github.com/LightBurnSoftware/Documentation/blob/master/VariableText.md#variable-text-in-lightburn

Yes, I understand there are some great uses for this feature, however the Date/Time was set for me automatically during the creation of the text. Had I not previewed the job before sending, I would have been surprised at what I saw on the table. I’d like to be able to set that up if I need it. I’d prefer not to have the software interpret that for me. I have a better understanding of this feature now so thank you for that. From this point forward I’ll just pay more attention to text features in my setups. Thanks for your great work and support.

The text mode setting persists, like all other text settings, so if you had used variable text and then immediately made some other text afterwards, without resetting it, the settings would have carried over.

I go back and forth on this - If you’re trying to set up a job using multiple variable text entries, having to click each one and apply that setting can be a pain. On the other hand, if you’re not paying attention, it can do what happened to you. Now that we can multi-edit text objects, I might have this one revert to “Normal” when you create a new text object, because it’s the only one not visible in the main window.

Makes sense. I’ve never used this feature though so persistence should be “Normal”. I am looking forward to using the serializing aspect of it. Very useful.

The text “suite 400” was created before the days and times. That text was set to “normal” by default.

What may have happened - If you use the mouse wheel while hovering over a combo box, it might change the value within it. I’ll look to see if I can disable that behavior for this specific control.

1 Like

This exact thing happened to me today when i was practicing snapping text to spline.
Scratched my head what could possibly make LB preview complete gibberish instead of my typed text.

The mouse wheel is a smart place to look to as the culprit. Thanks for the suggestion.