"The laser does not appear to be connected to your computer......"

Got this message when I tried to connect,I have changed controller,usb cable,uninstalled and re installed lightburn,checked all connections etc but nothing seems to work…HELP!

Have you checked you have the right COM port selected. Also occasionally mine will not connect no matter what I do, a simple restart of my computer later it connects first try. :thinking:

Sometimes it’s the simplest things that get overlooked which is the problem.
Power on laser first then computer, if it doesn’t connect , right click devices.
computer security allowing it through?

So I’m a brand new lightburn user. I’m in my late 60’s, and have worked in IT all my life as a software guy who was at home in hardware, I could hash out a circuit if I needed to, even build a simple one. The point is that I was completely stymied by Lightburn the first time I tried to use it. The software had just found my USB connected GRBL board, now it couldn’t talk to it, and the messages were rather opaque. “Device Busy” was the message, but obviously it wasn’t.

I mean, some free software package could still talk to the board.

Eventually, after my granddaughter left for the day (she was 12, this was supposed to be a big STEM project for her, I wanted her to have her name burned on to a piece of cardboard before she went home) I found out that, astoundingly, the fact that just because 30 seconds ago lightburn found my GRBL board on COM5, it didn’t bother to record that, and now I have to set COM5 from a list, the human factors people where I worked 30 years ago would have called that a “Violation of the principal of least astonishment”.

At the very least, the message should say, “no valid com port set, please set one”. If you can’t currently tell whether the com port is set, that should not be hard to figure out.

Of course, your answer could be, “now you know, glad you are past that hurdle.”

Problem is, well, but I’ll tell you what went through my mind… It was exactly, “boy, this software seems real slick, but if it won’t talk to my laser burner at all, well, I’m sure glad they have a free trial, because it is less than useful to me.”

Had you talked to my laser smoothly and also worked me through, in some sort of beginner mode, setting job origin and machine origin so that the head didn’t run for the stops when I started a job, I would have been real happy.

You guys are so familiar with the software that you are no longer capable of looking at it through a newbie’s eyes. I noticed something when I looked at one of your videos, and just to check it, I asked my wife, schoolteacher of many years, never worked as a programmer or IT person but the person in the office everyone went to. She saw it too. I didn’t set her up, I said, “Hey, look at this video for this neat software package I’m thinking of getting.”

She watched about two minutes of it and said, “what is the ‘that’ they are referring to?”

You constantly use pronowns without clear antecedents in your videos. This is a symptom of people who are so familiar with a thing that they know, that it never occurs to them that anyone doesn’t know what “that” is, and even when someone else in the office looks at the video they don’t see the problem because to them, the actecedents are obvious.

But to beginners in your audience, the antecedents are not obvious.

This is a complex piece of software and to learn all parts of it requires a steep learning curve, there is no question. But, well, I think you should structure it such that I don’t have to watch videos to get even a simple burn done on my junky 3 watt grbl driven laser.

Hi, (having a chuckle about comments) I know exactly what you’re saying.
I had to watch the videos a couple of times to realise what they were talking about, I’m almost 60 y/o so eyesight not great but still works.
In the vid’s when they mention ‘this’ and ‘that’ If you look real close you can just make out that they are actually pointing to whatever ‘this’ or ‘that’ is, with the mouse pointer which could be highlighted or something a little better so you could actually follow where it’s going :grimacing:
Ok enough of my moaning.
I was a ground worker for almost 40 years so never had anything to do with lasers, had home computers for several years but did nothing but played games on them.
Saw a couple of vid’s on youtube, decided to buy myself a beginner laser, downloaded lighburn and started using the laser at the end of December just gone.(I didn’t have a clue and some would say ‘still don’t’) :rofl:
It’s a little confusing to start with but I’m loving it and with the help from the people on here it’s pretty quick to learn just about anything about the software and your machine.
The people on here are a mix of beginners and fully experienced and more than happy to help…
Hope you enjoy it as much as myself :+1:

Hey, just noticed my response directly above to (shellhopper)new starter, has been attached to someone else’s query…
What’s that all bout???

You don’t have to do that - we do have documentation that covers all of this, linked from the ‘Documentation’ page on our website: Connecting to the Laser - LightBurn Software Documentation

The above starts with installing, walks you through configuring the laser, connecting to it, the basics of using and navigating LightBurn, and more.

The next release does actually record the COM port found, and if the device isn’t connected to that one, but there’s only one thing connected to the PC that could be the laser, it will try that one instead.

its an age thing you know, im closer to your ages and even though i spend a lot of time on different software, i still find myself asking millenials for a bit of help now and then lol

I tried turning the k40 on first,no luck. checked my firewall settings (bullguard security) and that seems ok too. Any more tips?

Also checked the usb ports,they are fine too as I plugged other hardware into them.

How do I check if I have the right com port?

If you have Windows it would be in the Device Manager

I had a similar problem and discovered that there is an intermittent fault in the machine’s internal USB cable. It has a USB “A” socket (female) on the machine control panel and on the other end is a USB “A” plug (male) which plugs into the control board. When I plugged my USB “A” (male to male) cable direct from the computer into the machine control board it worked fine. Just to check, I reversed the process and the fault re-appeared. This was happening more when the machine had warmed up.

What am i looking for exactly? I’ve looked in the device manager,now what? sorry to ask so many questions but I’m not au fait with looking where com ports are etc…

Hopefully you’re on a windows machine, if you are, open ‘device manager’
scroll down until you see ‘universal serial bus controllers’
Double click and it gives a list of what is in which usb.
Sorry but i’m not hooked to my laser at the moment but ‘double click’ each one in the menu,(probably only 3 or 4) it should tell you if it’s working properly.

image

Here is mine on my machine. If you plug in your laser the list should update and whatever one pops up is the port your machine is on, Conversely when you unplug your cable it will disappear off the list.

Not that you should need to, but if you need to change the Com port number for some reason. (I’ve had things that only work if their Com port number is lower than a certain value). You can do that by double clicking the device you want to change, then under the port settings tab, click advanced, then you can change the port number in the window that pops up.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.