The laser will NOT turn off during on cutting movements

I have a MiniGrble board hooked to my K40 laser because the M2 Nano that came in it was horrible! The Mini Gerbil works well except one issue. During the jogging movements when the gcode clearly calls for the laser to be off it keeps the laser on! It was doing that for all movements and then out of the blue it turned off after all the cutting movements ta on it’s way back to the home position. SO IT TURNED ON WHEN THE GCODE STARTED IT WENT THROUGHT THE CUT SERIES AND NEVER TURNED OFF BETWEEN CUTS AND AFTER ALL THE CUTS WERE COMPLETE… IT SHUT OFF AND MOVED TO THE HOME POSITION!!!
I I TRIED CHANGING THE $28 VALUE AND I MADE SURE THE “MAX POWER” VALUE WAS IDENTICAL IN THE SETTINGS AND GRBL SETTINGS $30 I tried 1000 and 255 values. My settings are listed in the pic below.
I hope someone can help…as of now I have a $600 door stop!:sleepy::sob:

Just checking: when you say you made sure the “max power” value was the same, I assume you mean the “S-value max” setting in the Device Settings window in LightBurn? That number should be the same as the $30 setting in GRBL.

When you say the laser doesn’t turn off, is it on at the same power all the time, or is the power changing?

I do notice that your $31 value is 1. What happens if you change that to 0?

You are correct in your first statement that the S max value power and my dollar sign 30 value was the same at first it was a thousand then I tried setting it at 255 and neither value made any difference.
As far as the power change I do believe that the power change has taken place I look back at the g code and it seems like the values are changing and it looks to be very different on the artwork.
As far as changing the 31 value I haven’t touched it because nowhere in anybody’s documentation have they said the change that I don’t even know what the value does maybe you can fill me in on that. I bought the mini grbl because it seemed like best plug-in play option. I just have no idea why it’s not functioning the way that it should when I say the laser does not shut off what I’m trying to say is in between the places where it’s supposed to burn and shut off to go to the next cut it does not shut off it just goes to the next cut and leaves a trail along the way before it used to leave a Scorch trail from home to the artwork all throughout the artwork in between cuts and then back home and then shut off but now for some reason I don’t know which value I must have changed to do this but now it will leave a Scorch Trail do the artwork during the artwork but when it goes to go back home it shuts off before it goes home and goes home without leaving a scorched Trail so at least I made that little bit of progress! This has to be some easy fix somewhere along the line I just don’t know what it is! I hope you guys can help me! Thank you for replying, David Sherman

" $31 - Min spindle speed, RPM

This sets the spindle speed for the minimum 0.02V PWM pin output (0V is disabled). Lower RPM values are accepted by Grbl but the PWM output will not go below 0.02V, except when RPM is zero. If zero, the spindle is disabled and PWM output is 0V."

The above is from the grbl docs on GitHub:

This is also a helpful resource for understanding grbl settings:

Okay I made some progress the guy at awesome Tech. Com told me to set it for grbl STM and that’s what I did and it was doing what I described before so I came home from work today and I said it for grbl M3 and it works great except for one thing when you go to frame the art work out and you hit the frame button it turns the laser on and leaves it on and when he gets back to the original spot it will literally burn a hole through the equipment if you don’t act immediately. I thought maybe it was the$31 setting like you spoke of so I said it to 0 and it still does it I don’t know what to think I got two steps forward and one step back however I’m very pleased that it’s not burning Scorch marks to and from the artwork that’s a big deal

One last thing because I said that to M3 grbl does that mean that I lose the M4 functionality of variable power? Thank you for all your help Dave Sherman

Switching to M3 mode would mean that you don’t get the M4 variable power behavior, yes.

LightBurn uses G1 commands to run the frame, so I can set the speed without affecting your rapid speed, but the power is set to zero for those, so it makes no sense that your board is leaving the power on. When the frame command is done, LightBurn sends a G0 command to put it back into rapid mode, and that will also turn off the laser.

Which version of LightBurn are you running? We have had some recent issues with Gerbil boards since a change made in 0.9.00. I thought that was fixed in 0.9.02, but there might be something lingering there. I have one of these boards now and should be able to do some testing soon.

OZ I will send a video if I can. And show you the issue. Another issue when I bumped it down to M3 mode the framing feature ends up being very unsafe when you hit the frame button the laser turns on does the square around where the artwork should be and then comes back to its top left corner and stays on it does not shut off and the first time it happened to me it took me a second to realize it and it plowed all the way through the wood and to the bottom of the laser frame it was pretty scary I just unplug the unit and got it to shut off since then I’ve done it several times and it’s still basically stays on the whole time. So in M3 mode the framing is a no-go but at least it works in the other aspect as far as getting the art to print.

Also the version of light burn that I’m using is 9.02

I would truly appreciate it if you can continue to help me also my trial is about to run out and I don’t want to buy this if it’s not going to work can you extend my trial until we get this working
Thanks again for all your help David Sherman

I have tried all the grble settings:
Grbl LPC- crashed the board!

Grbl- works greatframing works all other features work EXCEPT ONE! IT LEACES SCORCH MARKS BETWEEN THE ARTWORK. HOWEVER TO AND FROM THE ARTWORK IT SHUTS OFF.PIC BELOW LABLED GRBLHere is the link to the video:

Grble STMmovi

ng and frame features work good
However just like grbl it leaves the laser on during all movements within the art and shuts off to and from artwork.
Grbl M3…Cuts laser off just like it’s supposed to! However the framing is VERY dangerous! It cuts the laser on and it stays on after the framing cycle is over!
Also the M4 feature doesnt work

What is the last version that you know works completely with minigrbl
David Sherman

Try this one:

That’s 0.8.07, before a small change to the comms was made. If that works it gives me a direction to look. I had never tested Mini Gerbil before, only the previous Gerbil.

GRBL-LPC is designed for that specific version of GRBL, and will cause lots of issues if used on any other version. Normal GRBL or GRBL-M3 should work, but might not because of the comms change that was recently made.

I tried the above version of lightburn 8.07nd I still am having the same issues. The framing is still firing and the beam staying on at the end…This is very unsafe!

Can you please send me an activation code for Lightburn my trial is almost up and I’ve used the entire trial time working to fix these issues and if I cant get it working I’m going to have to use other software. I really want this to work! I have a new Minigerbl board on the way in case this one is bad I’ll be able to figure it out.
Thank you
David Sherman

Please send your trial key number via email and reference this thread. We can extend your trial while we continue to sort out your technical issues. Send to support at lightburnsoftware dot com.

I am going to delete your message as the information you provide should be kept personal to you. Please follow the instructions I provided above.

I cant find your email anywhere to send my trial code to?
David S

Send it to support at lightburnsoftware dot com.

This is so frusterating… I thought I had it and it started again. One time right in the middle of a picture I was burning. Do you have any experience running a laser while a 3d printer is running? I think one is interesting with the other. I had it turning on and off at the right times and then it started up again the only thing different was at first my 3d printer running and the second it wasnt. Then it started the 3d printer again and I t went haywire. I didnt want to stop my 3d print to confirm but that’s where I’m at…I’ve double and triple checked every setting and that’s the only thing I can fathom. Any input.

I don’t run any 3D printers from the same computer as I run my lasers, so I honestly couldn’t say. It’s not impossible that they could interfere with each other.

I’ve continued testing I thought I had it working yesterday but no go. Here’s a new one the pic below shows the art starting with the laser on on lead in. And the power is on full! Then spontaneously the laser goes down to the correct power and finishes without any scorch trails within the art. Then after that it continues to work with the laser staying in throughout the entire artwork. So I changed it from my PC to my MAC and it did the same thing. What sends the signal to the power supply to fire the laser and at what power is it the pwm cable? Because the Lo cable is secure and in the right position!
I’m stumped!
David Sherman

Oz I also included my settings.
Dave Sherman

Have you checked with Gerbil / AwesomeTech to see if they’ve ever seen this problem before? I’m not terribly familiar with the Gerbil boards or how they’re wired.

I don’t see anything in your settings that looks wrong, and it’s very odd that the laser is changing power while it’s moving around a single cut. It might be an issue with how it’s connected to the power supply, or the PWM rate that’s being used, but again, I don’t know enough about the Gerbil boards to advise you there.