The machine may be busy or paused? Ruida & Lightburn Bridge

Hello, I have a 60W OMTech Laser with a Ruida controller connected to a Raspberry SC15184 Pi 4. I use a MacBook with Lightburn and LightBurn Bridge. I can get it connected, see if on the network, and working properly, except I frequently get the “There was a problem sending data to the laser. The machine may be busy or paused.” message. But like I said, I have it connected and working, but get this message frequently. Any help would be appreciated.

The only issues I’ve found were a poor wifi signal. Might see if you can find a better placement of the Pi…

Good luck


Thank you for the response, The Laser, Pi and Laptop are all within a couple of feet and the wifi router is around 20 feet away. But I’ll try getting the Pi away for the laser.

That should be close enough for a good signal. Remember the pi must be outside of a metal enclosure. It has an internal wifi antenna.

Mine’s running a a Pi 3b… I have a Pi 4, but am using it for other things at the moment.

Good luck


It is also a good idea to clear out unused files stored on the controller itself. Ruida is known to act a bit funky when they start to get full. Worth checking. :slight_smile:

1 Like

Thanks for the response, the Pi is in a acrylic enclosure and sits on top of the laser due to a short ethernet cable. Maybe a longer cable to get it off? But I can see the Pi listed as Lightburn on the list of connect devices with the wifi.

Good, so how do I clear the files AND the prior job off of the Ruida?

First, you can open the ‘File List’ window, pull the list from the controller, then ‘Delete’ some or all as needed.

You can also clear the memory of the controller using the HMI (keyboard panel on laser).

While this is a different system, you will find similar on your controller. The exact steps for your model should be easy to find in the documentation that came with your system.

Excellent, I’ll give it try and let you know if that works.

1 Like

I’ve been battling this problem for a while and need some help.

Using a Ruida RDC6442G that Lightburn complains “is busy or paused”

It works for the first few projects in a session then this problem starts happening.

Was connected via ethernet when it first started happening.

Added the Lightburn Bridge - no improvement.

Deleted all the files from the controller - formatted the memory - no change.

Was going to see if there was a firmware update but from what I can tell, I’m running the latest 8.00.67 Ruida firmware

Anyone re-flash their controller to resolve? Do I need a new controller (this one is only a year old)?


1 Like

I have a generic 100w laser with a ruida controller and a 3b pi lightburn bridge as well, and I often get this busy/paused message even though the control panel says it is idle. It seems to often happen after running a few jobs. One odd thing is that the framing command can work fine but when I ask it to start it gives that message. Sometimes I can get it to work again by hitting the rescan button and reselecting the bridge, or restarting the laser. Maybe just giving it some time is letting it work again.
I am in Florida in this ridiculous 85°f November heat and have wondered if it could be related to the temperature of the laser tube and the controller is protecting the tube by not working if the tube is too hot. Another clue is that if I have a job with a lot of cutting it seems to want to quit in the middle, where if the job is mostly low power scoring or engraving it seems to happen less. I set my chiller to absolute temp mode so it is aiming for a particular temperature instead of the “intelligent mode” which cools it a few degrees below ambient. That also seems to help. I am getting the AC to vent into the garage and am insulating the door and ceiling, which should help, or maybe just make the garage more comfortable.

How does your controller know what temperature the tube is… wired to the chiller?

These should not cause any issues with the communications… The controller doesn’t care unless it’s attempting to execute a layer or job.

This is worrisome…

What type of device do you have ? … a chiller or refrigeration type? A few degrees below 85॰F I would not think sufficient for a coolant… I run mine at 20॰C (68॰F)…

Is there some kind of error on the machines console? The Ruida loads the complete file into it’s memory, so it sounds like it’s detecting an error such as coolant flow or door open or you have some kind of hardware issue.

I would not attempt to upgrade the firmware unless you have a good technical reason… a shotgun approach is not one of them…

Good luck


Rather than reboot/rescan etc…you may be able to achieve similar results by resetting the connection by right-clicking on the devices button.

I sounds like you normally use the Start button in LightBurn? - do you get the same error if you use the Send button?

What is the model of chiller? If it is the common CW3000, the temperature of the chiller may not be able to go much below ambient as it just runs the water through a radiator with a fan blowing the same ambient air past the coils to remove excess heat, but doesn’t actually “chill” in the full sense of the word.

I tend to agree with @jkwilborn on the firmware, best to leave it alone for now. I think I read somewhere that it can be difficult to re-flash old Ruida firmware if you change your mind (can anybody confirm this?).

1 Like