There is a problem sending data to the laser

I saw this issue addressed previously but didn’t see a concrete answer. I’m getting the message “There is a problem sending data to the laser. The machine may be busy or paused.”
I have two Windows 11 pcs running Lightburn. Connected to an OMTech 60W CO2 laser with a Ruida controller.
Things work fine for a while they all of a sudden I get this message. It’s happend on both computers. I rebooted one and it worked again, but then quit working. I just rebooted the second computer and still the same problem.
Does anyone has a definitive set of steps to take to resolve this issue. This is very frustrating as I don’t know the source of the problem.

1 Like

Are you connected over Ethernet or USB?

Ethernet is much more dependable, but it’s probably lost it’s connection…

Check the laser window for a ready or disconnected message in the top left. You can right click on the device tab to reset the link…

If you’re using USB I’d suggest going to your lan and Ethernet…


HI Jack. Thanks for the response. I am using USB and things worked fine for a while. It seems to be an intermittent problem. I also notice that I get a message on the Rudia screen that says “no enough extend space.” Any thoughts on this.

Either this is similar to a slop error which is overscan related … I think it’s referring that you are driving it out of your work area…

Check your Start From and Job Origin values…

If the Ruida is full of extra files, delete them… it gets kind of cranky when it runs out of memory.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.