There was a problem sending data to the laser the machine may be busy or paused

Hey guys,
so my laser worked fine at first but suddenly stopped connecting.
Yesterday I tried to connect to my Sculpfun S9 (direct usb connection) and it just did not react anymore.
Will try to summarize the situation:

  • Windows beeps and shows a device in the device manager when I connect the usb cable
  • After turning on the device itself behaves normally (fan and orange led working)
  • Lightburn shows “Laser Ready” above the Pause/Stop/Start buttons (as soon as usb is connected)
  • Lightburn shows the correct com* port beside the devices button in the lower right corner
  • Lightburn console just says “waiting for connection”
    * Rightclick on Devices-Button will just result in another line of “waiting for connection”
    * Once the frustration hit me and I spammed the Devices Button a few times, the Laser
    reacted with a millisecond long warning shot, so it seems to still be still alive
  • When I hit Frame/Pause/Stop the button accepts the click but nothing happens and returns to normal
  • When I hit Start I get the error message with laser is busy or paused
  • I installed ch340 a second time via LaserGRBL, but lasergrbl does not get a connection also

Any ideas on how to proceed?

So, if you connect it to USB, the device manager shows a “usbserial” or CH340 device?
The messages in the laser window do not matter. You need to check the console. As long as there is no startup message displaying the version of the firmware, there will be no control whatsoever. Which COM port gets assigned to the laser? Is there any error message in the LaserGRBL console window?

image
Device Manager says USB Serial CH340 with the same COM my Lightburn shows.


where do I see the console window in lasergrbl?

It’s the white area on the left, under gcode hier eingeben. Is there any message if you click on the connect button?
Another thing to check: make sure the USB port is not blocked by another application (e.g. the 3d printing tool Cura will automatically block all USB ports if it’s running).

Nothing happens in the white area in lasergrbl. I only get
image

When I keep lightburn open lasergrbl says the COM port is blocked.

I do not think that something else blocks the usb, the notebook is fairly new and I did not really use usb devices as of now

ok something strange happens now. the behaviour is unchanged on notebook/windows side.
but when I turn the laser on… well the laser is also on and burns continuously (but still not responsive)

this is my first laser and I have no idea but this feels like the controller is indeed busy somehow, stuck somewhere or fully buffered with input it cannot process.
is there some way to clear it’s cache or something?

Have you tried a different usb cable? if possible try hooking up another computer?

Anything buffered will empty when power is off.

Next thing I would try is to re-flash the firmware. You can do it with LaserGRBL. Check if there are any error messages (if the firmware can be uploaded at all).

@runfel I tried another USB cable and another computer and got the same results

@misken can you point me in any direction for guide on how to do that for sculpfun s9? I don’t want to flash the wrong firmware

Sure, the update procedure is described here: Firmware Update & Settings - Diode Laser Wiki And don’t be afraid, you usually can’t destroy the mainboard with wrong firmware, it just doesn’t work as expected then :slight_smile:

thank you, I will check out and test it after work and feed back :slight_smile:

Ok I could not wait and tested a firmware update via lasergrbl and now it works again. You saved my day :slight_smile:
I did just test the connection and dry-moving the laser a bit and it moves really really slow now (Frame function and position laser function) in comparison. Is this something that will be fixed if I copy your recommended settings?

Actually engrave/cut something will be tested later tonight :slight_smile:

Yes. You need to change the default settings to the Sculpfun settings. Basically the steps/mm, max speed and acceleration values. They are listed in the table at the end of the page.

Yeah I adjusted speeds and steps/mm and now it works nearly fine :sweat_smile:

I did a test and compared the result with the simulation/preview I get with alt+p. It seems like the red lines which should just be traverse or moving are still engraved/cut.
Is there an option for this? It seems to not turn off correctly

Ok found the $32 option, need to get new material for testing later