"There was a problem sending data to the Laser"

“The machine may be busy or paused”
After running my Covid clear shield jobs two days ago with no problems on 10 runs of two shields each. I was using the Sart button on my Lightburn screen each time
Today I decided to use my 50 watt Orion Ruida laser on some other jobs. My laser is LAN connected directly to my laptop with the provided cord from Oron. My laptop is on WiFi. Same connection as my previous runs. After a bit of problem with Lightburn connecting to my laser I did one run on a simple project. I then added another test piece of cardboard and pressed Start on my laptop display. thats when I got the above message. I tried Escape, then Escape-Enter on the Ruida and still no control from the laptop and the same above message appeared. I did a power on reset on the Laser and nothing. I shut down Lightburn and still got the above message when I tried to run the job.I also erased the Files which was a previous solution on the same issue. I even pressed the dreaded Reset button on the Ruida. No help.
I’ve seen messages on this topic with a USB connection, but so far I havent found one with my situation.
Oh, I tried the RDworks software and I got the same problem, differnt phrasing, with it too after one run.
Any help on this would be great.

Can’t say it’s the same as I use USB and a lot else is different too but I get the same message a lot. I always go to ‘Edit/machine settings’ and press read. My pc then reads the settings data and I press cancel to get back out. Then it runs ok.

Thnx, I’ll try that out.

If you right click the “Devices” button it should reset the connection for you.

It’s because you’re on WiFi - Ruida controllers Ethernet protocol isn’t very complicated. It’s solid over a wired connection, but if it drops a packet over WiFi there’s no way to try again, so it just fails. If you use a wired connection or USB you won’t have issues.

So are you aying that my laptop should also be on Wifi?

Not what I meant.
The laptop should be on LAN too?

Yes - if you use an Ethernet cable to connect the laptop to the LAN, or direct to the laser, or use a USB cable, you should have no issues.

I have WiFi to Laptop. Lan from Laptop to Ruida controller.
Right now,
Machine power on, Rebooted my lap top, Started Light burn, Selected my Ruida, Was able to get machine settings no problem.
Ran three jobs back to back with no problem.
Just now closed Lightburn, waited a bit, Restarted Lightburn, Got machnes settings no problem, was able to start a run.
Still using the supplied cable.
I will say that I did make a Crossover cable and that didn’t work. I thought I checked it well, but apparently not. Even plugged in my homemade cable straight to controller with no success.Will buz out my cable.
So I think I’m up and running and have a scheme that works.

After another completed job I powered off my Machine then powered it back up. Lightburn was left running. I was able to read my machine settings and control the Axis movement of my machine. I also unplugged and plugged my ethernet cable once at the lap top and once at the machine. No problems reading the controller.

I have a 3018 with a diode laser, and an Ortur laser that Lightburn gave/gives Zero problems on.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.