Throttle laser power when speed increased

Hello, so I tried to search for this answer but wasn’t exactly sure I got what I was looking for. Love the software so far, just had a couple questions.

My machine is a large 2000mm x900mm frame with aluminum bars etc etc. Belt driven, with Nema 17motors that are .72nm(these were hard to find since they are almost twice the power of standard Nema17) I’m using a true 7w diode laser. By true I mean it’s output power is constant 7w at 100%pwm or 5v input. No fluctuations. The pwm settings work on the laser it can fire at 50% and so on when changed.

I have multiple boards but I’m going to be talking about one in specific. It’s a generic cnc controller from China and has 3 on-board drivers (which I bypassed for external stepper drivers tb6600) its a 8Bit grbl V1.1 board with the Atmega 328 chip.

Now I have 2 questions.

When I increase the speed to engrave(machine is in mm/min) to about 8000 and have 100% power On the laser I can get a deep nice and dark colour from the set up. When I go higher to about 10000mm/min, the speed of the engrave does not change, but the power of the laser reduces drastically even though it’s still at 100%power In the settings.

Now I’m thinking my 8Bit grbl board is the reason why the speed isn’t going up but why does the power decrease to the laser when going faster?

I ordered a 32bit board but I’m just curious, if speed increases why wouldn’t power of the laser stay constant? Why decrease power when going faster when you need more power to keep up with the speed. Is there a way to change this in the software or is my 8Bit board causing all these problems because it can’t process gcode fast enough and lags the laser power.

Can we also clarify that the reason the engrave speed doesn’t change when I type in 10000 from 8000 is because of the 8Bit board? I know my machine can go way faster, when I was using Mach3 it was like extreme but the laser couldn’t keep up with firing even with m10p and m11p commands in the gcode. Just looked scattered, maybe that board wasn’t good also.

Here are my settings for reference. X and Y axis only. No Z. Grbl settings are maxed for $120-121 at 1250. Board/grbl won’t let me go higher. As for $110-111, 29000 was safe before motors started to stall, I got to 35k but didn’t like the sound.


I’m only allowed one image since I’m a new user, I’ll put up my grbl settings and provide the rest if I get permission or per request. As you can tell my goal here is speed, if I have to buy a new laser then sure but even with the 7w there are issues before the power maxes out.

Normally I would say that you have your speed limits set too low on your axis, but that doesn’t appear to be the case. GRBL, when using Variable Power mode (M4) will reduce the output power to compensate if the controller can’t go at the requested speed.

It does this because that is how, in theory, it would need to deposit the amount of power you requested. If I run one circle at 100% power, 50mm/sec, and another at 100% power, 100mm/sec, the second circle will be half as dark as the first. If my controller can only go 50mm/sec, it’ll reduce the output power by half so the result looks like what I was expecting.

If you use the GRBL-M3 device in LightBurn, it uses Constant Power mode (M3) which doesn’t do this, however it also doesn’t adjust power output for corners, or shut the beam off if the laser stops for some reason, so we don’t recommend it.

What are you trying to engrave? If it’s simple vectors, the board should be able to go faster (like, a square or circle). If it’s an image, dithered or grayscale, then you’re hitting the GCode instruction throughput limit of the board, and probably need to lower the DPI, or use a dither mode that optimizes for throughput (Newsprint or Atkinson).

I was just testing a simple circle(Fill) I drew in LightBurn, so do you think if I upgrade to a 32bit controller and use grbl lpc it would solve this issue? That way I can up the speed and not loose power because the controller can handle the speed?

I can say that GRBL-LPC (or Smoothieware) will handle speeds of 250 to 300 mm/sec without issues.

I still don’t understand why your board is clamping your speed as low as it is, but you didn’t mention a clock rate or where you got the GRBL build from, so it’s possible it’s non-standard.

I’m pretty sure it’s at 16mhz, based on the information I provided earlier does 8000mm/min Or 133 mm/sec for 80step resolution sound like the max given the clock speed? I can’t see it being much higher if 300mm/sec is achievable at 120mhz.

I also think my max on this current board could be lower than 8000mm/min because I can’t tell too much of a difference between 7000 and 8000 for engraving speed.

GRBL on 8 bit chips has a maximum pulse rate of about 30kHz, according to the developer. Your steps per mm values are 80 steps, so in theory, you should be able to go 375 mm/sec (30000 / 80).

So upgrading to a 32 bit board using grbl-lpc definitely increased the performance. I can now use the machine at 18000mm/min (300mm/s) without the laser dropping power, any higher tho and it looses power. I wonder if there will be more software/boards that can go higher than this in the future. Seems like a bigger board is still limited by the firmware on the board. Thanks for explaining everything tho helped me a lot!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.