TL-3120 "problem sending data" after 1 or 2 files

I’ve recently come into possession of an Amonstar HQ7050 laser cutter with a TL-3120 controller (which reports as version, which I’m connecting to via USB. Lightburn can send one or two files, but then refuses to send any more with the error message “There was a problem sending data to the laser. The machine may be busy or paused.” Restarting Lightburn seems to fix the issue, but it’s annoying.

EDIT: I’m an idiot, found the manufactuer and model number on the top of the laser.

Did some more cutting tonight and did a little bit of experimentation at the same time.

  • Lightburn won’t control the laser unless it was started after the controller was powered on
  • Pressing any of the buttons on the controller will stop Lightburn from communicating with the laser until Lightburn is restarted
  • Restarting the controller, or if the USB connection is lost for any reason, will stop Lightburn from communicating with the laser until Lightburn is restarted
  • Starting a cut, running the perimeter, moving the laser head, setting the origin, getting the current position and getting the file list in Lightburn do not cause this.
  • Attempting to delete a file on the controller through Lightburn does’t seem to work, but I only tried it once.

Instead of restarting LightBurn, you could try right clicking the ‘Devices’ button towards the bottom right of the window.

I’ve been told of intermittent issues like this from other 3120 users, so it’s on the list to look into. As Blake mentions, right-clicking the Devices button might help - it disconnects and reconnects the communication channel to the controller.

Finally got back to the laser today, and confirmed right clicking the devices button solved the issue. Spent a little bit of time doing things I knew would otherwise cause a disconnection and right clicking the button fixed it every time.

Thanks for the help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.