Top wisdom issue

Hi, I am using auto Laser 2.21 with a top wisdom TL-403cb. I installed all the drivers but I cannot connect to the laser. Auto laser is able to connect. I saw somebody else with the same issue fix it by replacing the USB which I will attempt to do, however, before I get into that I was wondering if I had to have the newest version of the firmware and the newest version of AutoLaser to work or if it works with the version I have now.

How old is your controller? I’m using AutoLaser 2.5.1 with my controllers, but the version really shouldn’t matter. You can’t run AutoLaser and LightBurn at the same time though - only one of them can talk to the controller at a time.

The machine itself is only a year to a year and a half old. I’ve only been trying to run one at a time.

Do you think the drivers are different between the versions?

I don’t expect so, no. I have a 403CB here that I’ve tested with, and it works. Try the following:

  • Run LightBurn
  • Go to Help > Enable Debug logging (at the bottom)
  • Click the ‘Devices’ button and click ‘Find my Laser’ (assuming it hasn’t been found already)
  • exit the software

You’ll find a file in your Documents folder called LightBurnLog.txt - attach it here and I’ll have a look.

LightBurnLog.txt (1.6 KB)

ok, I uploaded it.

I’ve looked through the log file and I don’t see anything I recognize. If you open your ‘Device Manager’ in Windows, are you able to see the TopWisdom controller in there? If you can, pull up the properties and look for the USB identifier (VID / PID numbers). If you can find those, and they’re different to what I expect, I can add them and have it try to connect.

Is there a specific section in the device manager? So far I can’t find it but I have a sneaking suspicion this has something to do with it.

What’s in COM4? When you connect with AutoLaser do you see any information there? As for where it would appear, it really depends on how they’ve set up the driver. If I plug mine in, it appears under ‘Ports (COM & LPT)’ as COM5. It causes the list to refresh when I connect, so you could take a screen shot of your list before and after plugging in the controller and compare them.

Can’t be the (in)visibility caused by the virtualbox/VMware engine? Do you have correctly mapped ports? Maybe I’m wrong and it’s some kind of the remote desktop, but it’s simillar to some virtual machine, so I can’t be sure. What’s the situation in the host OS (macOS)?

it is in reg windows.

auto laser works with com 4. com 4 turns off and on with the laser. There is no specific name for the laser when its plugged into com4.

Can you try the ‘find my laser’ process again, making sure your laser is connected? I don’t see COM4 in the log you provided, only COM1, so there’s a decent chance that it’s using a different Vendor/Product ID pair than I’m expecting, and that might be all it is.

i did it buy it is the same.It just says usb serial port next to com 4.

I mean, in LightBurn, enable the debug log, try running “Find my Laser” in LightBurn again, and send me the log.

it just started working!

And thanks for the help.

It’s possible that the driver wasn’t fully installed until rebooting. Happy to hear it’s working.