Topwisdom rotary setup. Lightburn was wrong

Hi everyone. rotary problem. Rotary steps cannot be entered in Topwisdom. Topwisdom calculates them automatically. So we will have:

  • material diameter (the diameter of the material to be engraved, bottle, glass, etc.)
  • reference diameter (the diameter of the rotary)
  • reference resolution (practically the steps of the rotary based on the diameter of the material).
    In lightburn there is a mistake: they reversed the values.
    In the pictures you can see that I have an 80 mm rotary and a 72.6 mm bottle. In Lightburn it’s the other way around. If I manually invert the values, it turns out that I have a 72.6 mm rotary and a 80 bottle. And the automatic calculation goes to hell. It would be enough for Lightburn to reverse the destination of the data and the problem would be solved.

1 Like

@Tittidoby Thank you for reporting this.

I appreciate the efforts made to capture this, yet I may be misunderstanding part of the idea.

In your capture of the LightBurn Machine Settings window, I can not tell if you have swapped the Reference Diameter (mm) with the Rotary Diameter (mm) or if this is ‘as read from the controller’. The Reference Diameter (80mm) and Reference Resolution (26.20978…) are both the same in the LightBurn Machine Settings Window as it is in the AutoLaser Sys Parameter (Machine Param) window.

If I understand your statement correctly, in LightBurn while the Values are correct for all three Rotary Settings, LightBurn has swapped the numerical data fields for Reference diameter and Rotary Diameter and has not swapped the labels for the Rotary diameter and the Reference diameter.

I wasn’t expecting to see the Rotary settings in the Machine Settings.
I’ll get this into testing as quickly as I can.

Thanks again!

Hi JohnJohn, there are 2 solutions: reverse the labels or reverse the data.

I forgot, the data is what Lightburn read. I didn’t touch anything.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.