Totem S connecting Y-Axis

Hi there,

I got a Totem S and assembled everything correctly, but the Y-Axis doesn’t move correctly, the steppers only vibrate. I tried the steppers on the connection for the X-Axis and they’re working correctly there. I also tried them with the cable for the X-Axis on the connector for the Y-Axis, that’s also working fine.

So I guess that my problem is either that the firmware isn’t controlling the steppers correctly or that the wiring is incorrect.

I tried to change the wiring with a youtube video of someone assembling his Totem S, but sadly that wasn’t successful.

Could someone with a working Totem S show how the Y-Axis is wired? That would help me a lot to rule that out as a source of error.

Also, I have absolutely no idea what firmware is installed. Would it make sense to install another firmware to exclude associated errors?

If you tested the Y-port on the controller with the Y-motor using the X-cable and that works I would pretty much assume the issue is in the cable.

Can you not use the X-cable as reference and copy how that is wired? After that, in the worst case you’d have to invert the direction of the motor in case it’s going in the wrong direction but at least the motor would be functioning.

I’d suggest holding off on this unless you have definitive proof that the issue is in the firmware. You’d be creating additional variables when you’d ideally be limiting them.

That’s also what I assume.

Sadly I can’t. The X-Cable is a 1-1 cable to connect one stepper to the board. The Y-Axis cable is actually a Y cable, connecting two stepper to one connection on the board. That’s why I hope to find someone with a working Totem S to copy the pin layout.

Can you physically trace the wires from end to end? If not, do you have a meter with continuity or resistance that you can use to determine the pins? If so, would be a good time to test that all the wires have continuity. It’s possible the cable is actually damaged.

You’ll need to confirm if the motors are meant to turn in the same direction or in opposite directions. If they’re meant to turn in the same direction then the split Y-cable should have matching pinouts. If they’re meant to run in the opposite direction then the split would likely have one of the cable pairs reversed.

On other test if you haven’t tried it. Test only one side of the Y-split cable at a time. Are you having an issue with both sides or just one?

Yes, that’s the first thing that I tested and all wires have continuity. That being said, I thought about buying a replacement cable (when I googled the error someone mentioned that a different cable helped), but I can’t find a replacement cable.

The way they’re mounted I’m pretty sure they have to turn in opposite directions (https://www.geekmaxi.com/img/p/1/5/8/0/9/15809-thickbox_default.jpg). And yes, one side is reversed.

Yes, I tested everything, both are only vibrating, even with only one stepper connected. Btw when I write vibrating I actually mean that they do one step in one direction and then a step in the other direction and so on.

So, if I understand you correctly one stepper has to be connected 1:1 and on the other stepper one pair has to reversed, do you know which one? It’s a 6 pin connector, the pins 1,3,4 and 6 have a connection. 2 and 5 aren’t occupied. I guess 3 and 4 have to be reversed on one of the steppers?

Thanks for the help, I really appreciate it.

You’ll need to confirm which pins constitute a coil pair. Try bridging every combination of the occupied pins and turn the stepper. The combinations that result in harder to turn stepper are matching pairs. You should only need to swap the pins for one of the pairs to reverse direction.

Once you confirm, compare that to how it’s currently wired. And compare against the X-cable.

At the risk of injecting more complexity, make sure the Y-axis acceleration and speed parameters are sensible. Given the additional mass, they should be no higher than the X-axis values; lower would probably be better.

In particular, if the acceleration is too high, the motors simply can’t start turning that quickly and will stall, producing the vibration you describe.

It may be helpful to test the motors in isolation, when they’re not connected to the Y-axis hardware. If you can get them running in that condition, then you can proceed with tuning the parameters to work under the normal mechanical load.

I forgot how to quote, so I will just reply this time.

I have one correctly wired cable (the one for the x-axis) and tried to copy that to one of the ends from the y-axis cable and I swapped pin 3 and 4 on the other and.

Then I tested each end with the stepper for the X-Axis. Well, one end was still vibrating and the other did nothing.

So far I did a lot of pin swapping and the plugs don’t look very good anymore. So I’m going to get a replacement wire for a fresh start and if I can’t fine one I will just buy 2 normal ones and solder a small adapter or something.

Thanks for the input, so far I hope it’s a hardware issue. But I will keep that in mind.

Did you test one motor at a time or both? You may want to test one stepper at a time. It’s possible that the motors are not getting enough current to both work correctly so try to isolate for that.

Did you check for continuity of the wires? If the cable now matches the working X on one side of the Y then that should absolutely work unless there’s a continuity or bridging issue. Make sure all wires have continuity at both ends and that there’s no bridge across pins potentially shorting things out. Once you’ve done that for the straight through path test on the side that you crossed over.

Only one stepper, there is only one on the X-axis.

As I already said, I did test the wires and they’re fine. However swapping around the pins a few times seems to losen the fit inside the plug, that’s why I ordered a new cable.

Isn’t the whole issue on the Y-axis with 2 steppers?

Yes, that’s why I used the X-axis stepper to test the wire. It’s not really possible to test only one stepper for the Y-Axis.

Update:

The new cable worked, but the stepper were rotating in the same direction. In order to change the rotation I had to swap the inner and the outer pair of one end. With only one pair swapped it was vibrating again.

The cable isn’t a Y-cable, it’s an E-cable, but it’s long enough, so, that’s fine.

I also tried the old cable again (with the new knowledge, that both pairs have to be swapped). But one end wasn’t working at all and the other end was vibrating always, no matter what I tried.

So, I will just stay with the new cable, thanks for the help.

Nice. Glad you got it to work.

Are you certain you were dealing with a coil pair? Trying to build a mental model of what’s happening.

We’re dealing with electricity here so this is odd. I’m guessing either there’s a short or a break in the cable and should be relatively easy to isolate. As long as you have the exact same connections in this cable as the other cable it cannot work differently. If you test every pin to every other pin on the other side of the cable you should be able to determine a short or break.

Either that or the connectors are not making good contact.

In any case, sounds like things are now working which is great.