Travel Resolution and Stepper Resonance Issue


I have a a “little” problem with configuration i think.
I try to use GRBL on Arduino Uno and Shield V3, both are clone, and i have an issue with movement.
At beginning i used a GRBL Controller but i change the laser diode and that board have a problem with PWM and because that i was forced to try an alternative of that, and the fast solution was with Arduino Uno.
The old board use GRBL V0.9, on the new one I tried several versions and in all cases I encountered different problems (0.9, 1.1f, 1.1h).
The only way to obtain a correlation between 1 mm of software and 1 mm of table was with resolution 5, everything else make a lot of resonance on stepper.
On this configuration when axis move straight everything is ok, but when i have a radius the problem appears, all the stepper go into resonance.
On old controller all works greate, i tryed the settings from there but the result wasn’t good.
I attached a pictures with the old setting and the new one.
I try to adjust the microsteps from shield but i didn’t receive any good result, The Vref is 0.96 and stepper Nema 17.
When i change the resolution to a higher value, for example 80, i can obtain better flow on lower speed but in that case 1 mm from LB will be approx 13 cm in reality.
Value $0 and $1 don’t do to much.

Any idea will be welcome.

Do you have the microstepping jumpers on under the drivers?

No, on the above configuration I’m on full step.
I try a few mode with jumper but nothing satisfying…
The driver used is A4988 .

Try putting jumpers on all three here


Then I would think your setup would work with resolution 80/mm and acceleration at 200.

The problem was from there, very simple, very easy, more than two day of trying… :slight_smile:
I tried a few combinations at first, but the result was below expectations and because of that I ruled out that it could be the whole problem from there.
Thanks for your time.

Resolution Stepper Arduino Problem.

Motor Stepper Arduino cannot be controlled.

Stepper Resonance.

Axis movement Arduino Issue.

GRBL Arduino Uno and Shield V3 Configuration Issue.

Lightburn Arduino Uno Shield V3 Settings Problem.

Stepper Motor Control Issue Arduino.

Nema 17 Arduino Uno Shield V3 Problem, Issue.

Laser CNC Diode Arduino Settings Problem.

Lightburn and GRBL control stepper Issue.

I can’t set up the movement of stepper correctly on Arduino.

Fine tuning GRBL, Arduino Uno, Shield CNC, Lightburn.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.