Traversal Lines vs loosing line strength, 3018 Pro GRBL 1.1f Woodpecker 3.4 7 watt

Hey there,

Thanks for the great software for starters! I’ve recently purchased a full license and am getting great use of Lightburn but I’m still getting a teething issue as I’m learning how to configure it just right.

I’ve read many topics about the issue of traversal lines and setting laser mode and in attempting to fix the issue I was having a secondary problem. I’ll share some images & my machine spec and settings to clarify what I mean:

Spec of my machine: Yofuly 3018 pro, grbl 1.1f Woodpecker 3.4, 7 watt 450nm laser.


So in the above, I’m using line mode, doing 1 scan and I’m getting traversal lines.

Having read each of the related topics, I went to the console and changed my ‘$32=0’ to ‘$32=1’
This then changed the effect, where instead of the layer strength being passed to GCode, instead it had this effect:


So what appears to be happening is that the scan for a line layer is being passed, but I’ve lost the strength having been defined. (The layer’s setting was supposed to take 60%, for what it’s worth I’d the Cut Tab menu set for 8% for power min)

So I’m not sure if I loose the layer settings once I set $32=1.

I’d the other GCode looking right:

Grbl 1.1f [’$’ for help]

$0=10 $1=25 $2=0 $3=2 $4=0 $5=0 $6=0 $10=3 $11=0.010 $12=0.002 $13=0 $20=0 $21=0 $22=0 $23=0 $24=25.000 $25=500.000 $26=250 $27=1.000 $30=1000 $31=0 $32=0 $100=800.000 $101=800.000 $102=800.000 $110=1000.000 $111=1000.000 $112=600.000 $120=30.000 $121=30.000 $122=30.000 $130=300.000 $131=180.000 $132=50.000 ok I took off $32=1 and reverted back to $32=0, then had read that you could avoid the traversal line issue if you just use fill layers instead of line layers but it was repeating. ![photo_2020-07-09_13-34-35|281x500](upload://239BfoeXeW79rlTvgkUulUbzBtt.jpeg) I'm not sure if this is because of the grbl-M3 setting? I think there's something small like that that I'm missing. I'd like to get to a place where I can use line only, but not fills, as the scan time with the kit I'm using goes from minutes to hours when that's the case. So my questions are: If I set my $32=1 and then the layers loose their strength settings, is that because I've selected the wrong machine mode? Should I be using M3 settings instead? I've a feeling the problem I'm having may lie in the Machine settings I've been using, as I believe the grbl 1.1f should allow for the variable laser, I'm just doing something wrong from what I gather settings wise. Again, thanks in advance for your support, loving the tool and just looking to remedy the issue. All the best, Kenneth ![photo_2020-07-09_13-33-26|666x500](upload://uBzGsNBxfme5fn1obxLE0sLWJBX.jpeg)

Sorry the post has become compressed, I was attempting to add carriage returns to make it legible but they aren’t saving with the edit!
Looking forward to hearing from you!
Thanks!

Read here: Configuring a 3018 CNC for use with LightBurn

Specifically there’s a paragraph talking about trying to make the controller go faster than the limits allow, and how it will reduce power output instead when in laser mode.

Thanks for your rapid response Oz, much appreciated! Keep up the good work! I’ll let you know how it pans out and I’ll be back if there’s anymore tweaking to be done. Have a good one, cheers!