Traverse (move speed between cuts) is way too slow

plase, anyone have an idea whats going on? Have Atomstack X40 Pro Max, cutting A4 cardboard with some model parts on one board, cutting speed set to 1400 mm/min at 90 percent, movement speed at 6000, but the speed at which the laser actually moves between SOME cuts in real is much slower. Funky thing is tha this is not happening between all cuts, just between few (like second video at 0:50 sec - fast move and 1:03 really slow.), but it is happening at the same spots during repeated try.

videos here: https://youtu.be/QcjmUxa44lo, https://youtu.be/OI39u8Hxqts

Using Lightburn, move speed set to 6000 mm/min, when moving laser head using controller in lightburn there are no isuues, works as expected, only in a job with series of cuts, some traversing is really slow. In preview I use values from controller, and during the job the actual time is longer than estimation (I got 5:17 in preview, real time is around 8:20 )

Do you have “fast whitespace” enabled?

whitespace

Yes, I tried this option too, but no change so far. Thanks anyway for suggestion. Weird thing is it is not affecting all traversing moves, but only some.

Also remember that not all the spaces between cuts are long enough for the laser head to accelerate to maximum speed. A bit like the corners.

UPDATE: I made some research and testing on that and it just acts weird. I tried to send separate G0 commands into console, and it moves as expected in all directions - fast. During the cutting, when movement is restricted to one axis, it moves also ultra fast. but when the movement is diagonal, like move 5cm to the right and 4cm to the top, it just goes in linear movement at the lowest speed possible. Atomstack support is unavailable now till Feb 17 because of new year and I have to cut a lot of stuff, and this issue makes it aprox. 30-40 percent slower.

Did you get any answer from their support? I am experiencing the same issue.
When doing a Material Test it goes super slow between objects.