Trocen AWC708S controller Z axis issue

Hello all,

I have an Aeon Mira 7 with a Trocen AWC708S controller. It has an autofocus sensor which when activated would cause the Z axis to raise until focus point found. I had to replace the focus pin and since then the Z axis will only go downwards and not up (even if the table up key is pressed it will go down). From my basic understanding (only had the machine 2 weeks) I read it could be to do with a limit switch. I can’t find anyway to run diagnostics on the Trocen control panel as was suggested by a Ruida controller user who said it can determine if any limit switches are activated. A bit stumped at this stage as to what it could be and the table is currently stuck at the lowest placement on the Z axis.

Any help or suggestions appreciated.

The controller thinks the switch is tripped, so it won’t allow you to raise the Z further. I haven’t seen a diagnostic menu on the Trocen controller, but a simple multi-meter should be able to tell you if your Z probe is shorted or not.

Thanks, I’ll get a hold of a multi-meter. Is there anyway to reset the controller or limit switch to basically tell it there is no reason not to raise the Z axis? I’m a bit of a novice as the last laser owned was a K40 with no Z whatsoever so this is all new.

You can simply disconnect the switch. Relatively few users actually like auto-focus, because when it fails, it tends to damage things. If the Z sensor gets stuck in the ‘off’ position instead of ‘on’ like yours, it has the opposite problem - the bed will continue to raise after the sensor is contacted, and it can keep going into the laser head.

I’ll have a go at disconnecting the switch and update if that is it resolved. Decided to abandon the autofocus for sure, it was slightly convenient but as you say when things go wrong they go very wrong. I can imagine the opposite scenario of mine being a lot worse where it will only raise - could wreck a brand new machine

Just a quick update and resolution - was able to resolve this issue by removing the table and manually raising by turning the belt (not sure why this was necessary but until this was done the controller would not allow upwards movement on Z axis even with limit cable removed). I also disconnected the autofocus and the limit cable as suggested (on this controller it is the white colored Lmtz- wire). In the manufacturer settings hard limit and autofocus for Z is now disabled. Everything seems to be working normally and will be using manual focus from now on :sweat_smile: