Trouble closing "shapes" (line soup)

This is an issue with a couple shapes in the same “line soup” file imported as a dxf file. I’m starting a new thread because I don’t want to hijack the OP’s thread.
I managed to manually edit the nodes in all the shapes and get them closed except these two. I will attach the file and a screenshot showing the offending nodes. No matter what I try I cannot get these two points to connect.
Any help getting this closed is appreciated.

shape-close-test.lbrn2 (21.4 KB)

shape-close-test-fix.lbrn2 (21.4 KB)
I believe this should work.
its done in a very stupid way though.

Started by selecting shape, going Arrange>Break Appart, then Edit and Auto Join the shape back together.

I spent a long time connecting all this line soup. Why would breaking it all apart and starting over make these two points connect?

if I knew or understood why, I’d probably be able to program.

When you have two (or more) green squares in a shape, it means that you have open lines or segments of your shape.
It is sometimes very difficult to see and find these small gaps. The automatic function of first separating all points to collect them afterwards is “usually” the best tool for the task. Only if the distance between the points is too large does it not work, but then you can usually see it by the visual control.

1 Like

now that makes a whole lot more sense.

1 Like

I purposely left those two points separated like that. No matter what I do I cannot get them to connect.
The green dot at the bottom IS connected…
I’m stumped

Have you tried “Break Apart” and “Auto-Join selected shapes”?

Well, I don’t know why, but that worked.

I have to admit that I also sometimes have problems with unconnected shapes and I wish it was more visible or easier to connect them.
But often I don’t bother looking for the errors, it’s faster to use the automated “repair” function (auto-join).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.