Trouble connecting Totem S to lightburn

Hi all,

I’ve been struggling to make my recently acquired TwoTrees Totem S engraving machine work with LB on macOS Mojave (10.14). Connection worked fine during initial set up at home, but since then, i’ve had several issues :

  • When I tried connecting a second time, at some other place than my own, LightBurn was never able to detect the machine (laser stayed “disconnected” + device wizard in auto “find my laser” mode remained empty + manually recreating the device didn’t help + tried using a second computer, same issues).
  • I booted up the software & laser for a 3rd time today (last day of my LB trial period) – and it all seemed good (device remained in “ready” mode) until it suddenly switched to disconnected : my trial was over. Seeing that this was the only ‘parameter’ that had changed, I decided to buy and activate my license, but since then, the machine is never recognized (same issues as during my second attempt detailed just above).

I’m connecting the Totem S by USB (USB B in the machine, USB A in an adapter, USB C from adapter to computer).
Could it have something to do with IP addresses ? The fact that it didn’t work when out of home but worked again at home seem to indicate something along these lines, but just wild guessing, and no apparent relation to license activation breaking the link again.

Some help would be much appreciated !! Thank you