Trouble Downloading to Windows 10

I’ve tried downloading multiple times, updated my Windows 10, and tried the 64bit and 32bit versions. I can’t seem to get this to launch. I’ve read else where this could be an install location problem? How does one change the location? I’ve also ran it as an administrator so I don’t think permissions are an issue. Thoughts? Surely it’s an OS issue.

I’ve moved the file into C:\Program Files and created a folder for LightBurn, but this did not give any different result.

Install this first:

So, this is a bit of a chicken and egg problem that I didn’t anticipate. The installer is trying to check the license key to see if it should proceed - if your key is expired, it won’t overwrite the version you have. To do that, it runs a small app, and that app depends on the Microsoft libs that are about to be installed by the installer… You see where this is going?

I’ll have to re-order things a bit so the Microsoft stuff installs first, then it does the license check, and have it eject if that check fails. For now though, just installing the above should fix it.

1 Like

Thanks for your prompt response! Unfortunately, the given link does not work.

I’ve posted updates to the main installer. Please re-download from our Download / Trial page and let me know if this one isn’t working. It’s tough for me to test these, because I have all the required libs on our dev systems.

1 Like

That worked beautifully!! Fully installed with no issues. Certainly buying the license with that kind of service! (A pretty amazing program you’ve created too [not my first time using it]). Thanks again!!!

We don’t always get everything right, but we always try to make it right. Welcome aboard. :slight_smile:

1 Like

A little late to the game but I just downloaded the 32 Bit installer and it installed and ran on a Dell 32 bit laptop with Win10 - Thanks for the quick upgrade

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.