Trouble importing SVG

Same problem as Kirsten had on jan 13th. Our school likes to use Vectornator and import these in Lightburn 1.0.04. But also as Kirsten experienced Lightburn does not responds (it gets stuck) every time, so I don’t get a crash report. Even by the simplest file (one square) created by Vectornator.

I have tried it on two different pc’s. The file opens correctly in Inkscape and several online SVG editors, and even converting it in Inkscape to a standard SVG does not help.

Converting the drawing in Vectornator to a PDF or AI is not a option

Can you upload a sample SVG? just add .TXT to the end of the filename when uploading.

Unfortunately, even with the extension changed, this forum robot recognizes it’s a .SVG.
When i check it out with SVG viewer & editor online
I got:

<?xml version="1.0" encoding="UTF-8" standalone="no"?>

I hope you can use this


Ok even that doesn’t work. The robot changes the text.
Only a picture can be loaded

If you have something like Google drive, put it there and post a link to it. Ensure you set permissions for anyone with the link to read it.

:smiley_cat:

This is odd. Investigating as that should allow you to upload here. I just tested with my svg and found the same. Efforting, but for now…please host the file and provide public access, we can go from there. :slight_smile:

Edit: We have opened up the forum to allow SVG file posting without name change. My example:

Living hinge Flowery edge

1 Like

Hi there,
Here is my example .svg file
Square 200x200mm

Thanks Rick, that I can upload this

In the meantime Ralph contacted me and he has helped me already quite a bit (thx Ralph). He discovered that a PDF file from Vectornator “contains the square with a stroke and no fill, and also a square with a white fill and no stroke (when he looked at the data in Adobe Illustrator). What Ralph did in Lightburn was select all and delete duplicates”
that’s a major step forward but I’m still looking for the option within Vectornator to turn off the white fill if I don’t need it. To be continued. …

Also I’ve tried several .svg to dxf online convertors to import it in Lightburn as a dxf (like Convertio, cloudconvert, anyconv and freefileconv), but just as Inkscape they change the aspect ratio.

The only convertor so far which keeps the aspect ratio ok is www.svgviewer.dev This online tool optimizes .svg files but removes the layers option.

Ralphs suggestion was to use the .pdf export function within Vectornator. However with both svgviewer and pdf I lose a lot of functionality. And it remains strange that Lightburn gets stuck

If you open the SVG file in a text editor, and replace every occurrence of + with a space, and delete the code for width=“100%” and height=“100%” I can get it to import into Lightburn at the correct scale. Not very elegant, but it works. Also, it isn’t exactly 200mm x 200mm, but that has to do with the exported SVG code from Vectornator.

I just copied from Vectornator, pasted into Lightburn. It pastes as an image. That works, but doubles the size from Vectornator to Lightburn. It also puts a dashed line around the box.

Thank you all for thinking with me, especially you Ralph.
For my students I’ll write a two way optional work around:
1: Use the the text editor and change the .svg file according to Ralph’s suggestion
or
2: use svgviewer.dev

My final conclusions:
There is a little bug in Lightburn’s .SVG engine because:

  • Online .svg monitor/editor program’s are showing the Vectornator files OK although the aspect ratio is mostly wrong.
  • The fill of objects are removed in Lightburn
  • Lightburn gets stuck when trying to open such a file

However: this is not a major problem because of the fore mentioned solutions

Thereby Vectornator has some quirky things, for instance, when you want no fill to be saved, you simply turn the visibility off, so I have to learn more about this app.

I think the 2nd choice would be easier. Assuming that Lightburn is only installed on computers attached to the laser(s).

Your students could export their SVG file from Vectornator to a cloud drive like Google or Dropbox.

If / when they are on the computer that runs Lightburn - Open svgviewer.dev

Open their SVG file that they exported from Vectornator.

Select the “Optimize” button. It cleans up the SVG code.

Right click in the svgviewer window and choose Select All

Then select Copy

Switch to the Lightburn program and right click and Paste


A major issue here is that the svg standard is so loose.

:smiley_cat:

image

Thank you again Ralph, to display once again one other option within Lightburn. I didn’t knew that it was possible to paste svg code directly.

My solution was to export the svg file from Vectornator by email or cloud drive, clean it with svgviewer.dev and download this file with the button on the right hand side, which you can see on the screen shot.

The advantage is that the students can deliver a clean file and they do the job. I’d like them to experience that files aren’t always as compatible as it seems. But that is didactic reasoning.

And yes Jack the different generations of SVG conventions makes it difficult. (I’m glad that I’m not a programmer :wink: ) but still: Lightburn shouldn’t get stuck. I can handle such a event but I can imagine that people with less computer skills gets a little scared when this happens.
I posted this problem of course for myself, but also to improve and promote this great program :heart_eyes_cat:

I swear every new application I see that produces SVG files tries to do something cute with them that’s technically legal, but dumb. Using +'s instead of spaces is a great example of this - I’ve never seen anything do it before, and it’s technically legal in the SVG spec, but weird.

I’ve altered the SVG importer to handle the +'s in the path definition, so now I get this:
image

The size is 150mm, which I suspect is because the exported SVG doesn’t include a real size, just “width=100%”, meaning it’s up for interpretation, and InkScape’s default scale is 96 DPI.

I’ve changed the importer to use the InkScape / Illustrator scale setting when it encounters a file specified in ‘percent’, so the next release imports the file as expected as long as you have the SVG Import scale set to 72dpi (Illustrator) in the settings.

2 Likes