Trouble with axis since 9.0.9


I am using an eleksmaker equipped with endstops and grbl 1.1f und windows 7 64bit.

Since my update to the newest version, incl. up-update, i have problems with the axis.

When homing, it drives in the wrong direction. Inverting axis in Lightburn doesn´t help.
When driving the axis in T2 laser everything is fine. Driving in lightburn Y axis moves only in one direction.

Where can I find an older lightburn version to test if it depends on the update and how can I solve the problem in the newer version?

Hello Jan,

Look here.

All previous versions of LightBurn can be found in our version archive at

I also had problems updating to 0.909.
With me, my com did not connect anymore.
And if it worked, then I had the problem when I went to break after 20 minutes, he started after that no longer and was also no longer controllable.
after downgrading to 0.907 it worked again wonderfully.
But I think that they will patch that soon.

Greeting Andre ’

Nothing changed in the underlying communication code between 0.9.07 and 0.9.09 - your laser losing connection after 20 minutes is not likely due to the update.

Update to 0.9.09 again. A patch has been released to address the issues with older versions of GRBL or systems that do not have limit switches or homing enabled. A new form of jogging was enabled, because it is supposed to be valid on all versions of GRBL from 1.1 up, but apparently it is not. We put it on a switch, and disabled it by default. You should be ok with the 0.9.09 version again.

Hello Oz,

Thanks for the tip.
it works with this version.
Now it works well with the connect.

Thank you for your work and help.
As always, fast and good.

Greetings Andre ’

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.