Troubleshooting noob

Alright I’m sorry I tried not to have to resort to this but I can’t find help or a answer anywhere and I don’t know anyone who uses laser engravers so I figured this platform may be able to help me. So I seen a great deal on a laser engraver and couldn’t pass it up. Of course it’s some Amazon cheap Chinese made laser but it seems pretty sturdy and strong and should be great for me to learn on. The only problem is I can not for the life of me figure it out. I got it assembled and running. It’s plugged in belts run smooth the guide lasers out and it homes to the top left corner. The laser came with a thumb drive and some Chinese videos which I followed (to my best ability) on downloading the driver and the software to use it but I can’t get my laser to connect to anything… it came with a usb to what I believe is a Ethernet connection and it says it can also connect via WiFi to my phone through a mobile app. When I plug it in my computer makes the noise to say somethings plugged in but it doesn’t show anything in my task manager. When I unplug it it makes the disconnect noise so I’m thinking the wire and plugs aren’t the issue. And although I followed the instructions on the app it will not connect. I tried to use light burn but When I do the scan it says no device found and I don’t see a manual option to pick the laser I have or maybe there is one but it’s just in a slang I don’t know yet (like I said I’m a noob) anyways I’m running windows 10 and the laser I bought is a HTPOW JL1 but the instructions take me to another website called wanliux which has another JL1 that looks just like mine. Im assuming it’s the same just another Chinese affiliate. Anyways any help is awesome thanks guys!




1 Like

What driver and software did it direct you to use? The key is to determine if the controller runs a controller firmware that’s compatible with LightBurn.

Unless the laser is running 2 different firmware internally these types of lasers generally don’t work with LightBurn. There are some that do run different firmware so it’s still possible.

The photo you took of the board shows an STM32 MCU which is a common and capable chip used in laser controllers.

Can you check Device Manager and identify the COM port that the laser is being assigned when plugged in via USB? That’s the COM port that you will need to use in LightBurn if it’s indeed capable of being supported.

There should be an option for manual creation. Take a screenshot if you can’t sort out how to get there.

Hey man thanks for the reply. Unfortunately my old lady is going to shoot me if I get out of bed again at this time of night to go play with it lol. But I will try again in the morning and post pictures in here if the software and the com drive. I appreciate the response!



Not sure if this helps but this is the driver and software properties that they had me download and the app it downloads.



And here’s the driver


I believe this is the laser

This is the engraving app it comes with and my machine just never connects

Doesn’t connect to the native software or to LightBurn?

If you can’t connect to native software then there’s likely something more fundamental not working correctly. If LightBurn it could be because it’s not supported.

Do you have a serial communication program installed on your computer? Would be interesting to see what comes back.

In LightBurn you could try creating a manual device. Follow the instructions here:
Manual Creation - LightBurn Software Documentation

Use GRBL, USB-serial, front-left (bottom-left) for origin as your choices. Choose COM5 in the ports selection of Laser Window. Then check the Console window for any messages back from the controller. Enable “Show All” tab to see more communication.

It doesn’t connect to the native software. Thanks for the tip I’ll try to run it on Grbl on light burn

And I don’t know what the serial communication thing is or how to run it :rofl: like I said I’m a noob but I could do it and show you the results If you told me how to!

Alright I did the manual setup and there was a little tab over here that said something about laser not connected. I tried to minimize it but i accidentally closed it before I could take the picture to show ya. But I think this may be important for you to see?


These are the instructions and the connection should turn blue but mines just stuck in a endless state of connecting

Here’s the console show all view it just keeps repetitively typing G0

My guess is that it’s not actually a GRBL device which would leave you hanging. The fact that it doesn’t connect to the native software is a bad omen, however. Have rebooted your computer since installing? May be worth a shot.

Also, for native software you may need to set the port in the “Set” Settings area. Not sure how it would know how to connect otherwise.

Can you share web links to information about the laser?