Trying to connect MacBook Air to Thunder

I am trying to connect a MacBook Air M1 to a Thunder 24. It’s not recognizing USB, so I tried setting up with Ethernet. I have a cable plugged into a hub on the MacBook, then to the Ethernet port on the Thunder.
Using info I found here, I checked my ip on the computer - I set the Thunder to
I set the device up in Lightburn with those settings, but I’m still getting Disconnected.

I tried the FTDI update suggestion but it fails with a error that the application its trying to update must be in the /Applications folder, which as far as I know, it is.

Using the Network control panel I see an IP address of - different than ifconfig reports.

Does this address ID itself as the laser?

Let me clarify what a ‘hub’ is with your mac, just a way to split the Ethernet to separate ‘sockets’.?

This is the localhost address

I suggest you use a different IP for your machine.

When I set mine up originally, I set the IP of the port to something common. It was DHCP, so I had to assign it an address and I used the for my machine and set the lasers gateway to that IP, I used something different on the last octet for the laser, like…

Most people let it run through the network. Although the Ruida has a static ip, your machine probably doesn’t. If you connect via a network these are handled for you.

Good luck


Thanks, I’ll give that a try. By hub, I mean an external adapter with USB2 and Ethernet that plugs into the USB C port on the MacBook Air

Sometimes just figuring out some of the ‘jargon’ clarifies the problem. I don’t really know how a USB <-> Ethernet is configured. I have never used one.

The device has to have an have an IP address, how is that handled…?

Do you have a manual or something on it?

I had great success with a cheap bridge from Amazon

I dumped it for the Lightburn Pi Bridge, that I’ve run for a while…

A wired Ethernet is probably superior, at least connection wise. The Pi Bridge has code in it specifically to address issues with the UDP protocol for the Ruida controller.


I set the up on the Ruida to
On the Mac, I set the port to use dhcp but manually assigned
Both have subnet set to 255.255.255

Still not showing a connection in Lightburn.

I usually don’t have problems figuring things out, but one is giving me fits

Most local WiFi uses 192.168.1 subnet. Don’t want them interfering.

If the device uses dhcp, the router will supply the IP out of it’s pool. The statement is conflicting.

I’d try setting it to for your computer… leave the laser at 101 and set the gateway on the laser to… or to your computer…

Machines have a tendency to … go to the gateway… you want it to go to your computer… make that it’s gateway… The gateway is pretty much ignored on these things… and shouldn’t be…

If I had one of those hubs, I’d try it on my machine.

I’ve plugged my Linux box and the wifes Windows machine directly from the Ethernet port of the computer…

If you change the IP, I think you have to reset or reboot the controller. Some things that you set on a Ruida, needs a ‘reset’ to read and implement the new information…

That’s well documented… somewhere I’m sure…


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.