Trying to fill text imported as DXF, some are not "closed"

So I made a file in V-Carve, and exported as DXF to Lightburn. I used an outlined font that has most of the letters showing up as closed and will show a fill operation correctly in the Monitor tab.

After Ungrouping everything, I could use teh Close Path feature to fix two more, but some just will not fill. They used to have small gaps, but I went back in V-Carve and fixed each one I could find using Join Vectors. The close up is as close as I can zoom in on the tip of a lowercase R.

I searched the forum, and saw a similar post about importing DXF Vectors but it auto closed with no responses.

Any thoughts on how to solve this?

Without seeing the file itself it’s hard to say for sure, but I’d suspect that the geometry of the r looks like this:


That small square that’s unfilled could be made its own object, and the connecting tail just drawn as a line between them - That would fix it. Can you post the file, or the letters that aren’t working at least, so I can have a look?

Yes! That is what is USED to look like from the first export. So I went back in and Auto Joined the vectors in V-Carve so it made a straight line from that hanging point to the line above it. Then I saved and re-exported. Now it is closed. At least from everything I can tell. I even tried exporting as SVG, save exact result… I fustzing with V-Carve some ore to see if it can tell somehow!

Here is a clip from Lightburn edit screen, rather than the monitor, ZOOMED way in.


As a newbie, looks like I cannot attach my Lightburn project or the original DXF so you can see yourself. Just pictures for now

You can email the dxf to developer at lightburnsoftware dot com and I’ll have a look. It doesn’t appear that your 2nd picture posted either, which is odd.

You should be allowed - I looked at your account settings and I don’t think you’re restricted, but we might not have DXF as an allowed type, or there could be size limits.

I will send it in. I got the pop up that New Users are not allowed to add attachments when I tried the .ilb file even though it is in the list of allowed… O.o

Sent in the .ilb and the .dxf

I updated your account. Probably just before Oz looked at it. :wink:

1 Like

OK, for the Forum to see, here is my .ilb file :smiley:

Point out my oversight, it’s driving me bonkers.

Dragon.lbrn (241.2 KB)

Taking a quick look, I see there are still open shapes set to Fill in this file. You can find them using ‘Edit’→’Select open shapes set to fill’.

You can then use ‘Edit Nodes’ to see where the shape is open.

I have not gone through the entire file to correct, but this LightBurn file still has some issues being introduced during the generation in your source art software. The ‘Fill’ and ‘Fill+Line’ require closed shapes to work.

If you zoom way in on the r, it looks exactly like I showed in the image above.

Drag select here:

Then press Ctrl + Shift + A (Zoom to selection)

That little line goes from the long edge along the top to the shorter edge along the bottom, but it’s not connected - it’s a distinct part, and the rest is as I drew it above. I’ve changed it using node editing to make the square a closed shape. Have a look at how mine is built (attached).

Dragon.lbrn (241.4 KB)

More generally, if you use Edit > Select open shapes, or Edit > Select open shapes set to Fill, LightBurn will highlight the problem bits for you.

The t is just not closed (there’s a small line on the top-right of the horizontal cross-bar). The h, b, and n have the same issue as the r with the line piece being disconnected / not closed, and the outer line around the design is just a line, not a closed shape, so you can’t Fill that without closing it.

Checking this out now

OK, so I went back into V-Carve and used the R tips as my test. I deleted the little line I made to patch the hole, and instead used Node Edit to move the existing like to snap to the line it should be touching.

Saved my work, exported the DXF and reimported to Lightburn. It hates me… I don’t seem to be able to fix the spots I knew were wrong.

At teh base of the file, I also checked those arcs, and they were snapped to the rectangle as well, no gap in the v-carve screen.

Hrmm. maybe just a different vector editor? I hear Inkscape is free…

Oz, Your fix works… what did you edit with??

Well all be damned… so on those R’s, if I ask V-Carve to close them, it draws a line from the tip of the box back to the single line start of the feature, and since I have them snapped to that line anyway, it makes that line double thick… hard to put into words… So I suspect the Laser path will draw that twice and make a deeper etch? (Or will the Over Lapping Lines setting prevent that? Always wondered about that feature.

OK, got it sorted, this is what I wanted. Will look nice as an acrylic lamp display!

Thank you very much, both of you!

I made the changes in LightBurn, using Node Edit.

I find some programs DXF exports will do that (leavesome shapes open), but exporting as AI solved it entirely, on the software that can import AI files. We have one laser that cannot, so I use E-cut’s corel macro for DXF export, and that solved all the hiccups i’d had with DXFs.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.