Trying to identify my legacy laser controller ROLC320-A (EC) inside an Apollo 600- ruida?

I have an apolllo 600 laser cutter with an RF laser dating from c. 2012, sold by cadcam technology / Gsuk in the uk, which I know they assembled from stock parts.

It is working - currently running APS-ethos. It’s been in storage for some years - and they say it is obsolete and completely unsupported. In anticipation of a major (computer) failure - I’m trying to work out what other Software would drive it (Eg lightburn!!) that is supported.

The controller inside it is a cream box, with “udisk” on it, and a silver sticker with ROLC320-A (EC), and S/N : RD 4000220 on it. Googling seems to imply this could be a ruida controller -(as I found mention of one with a similar but not identical number RDLC320-A but can’t find anything out about it.

The laser cutter has a Lilliput 7 inch (usb) touch screen mounted on it, which is driven by the computer as its interface.

Aps-ethos requires a dongle to work (which I have) but if the dongle dies -
The software will become scrap.

Does anyone know is this is a standard controller and could point me to a manual or something to get my teeth into ?

On the PC the drivers seem to work via some software called “Apollo” which drives the 7 inch screen as a second screen from the PC displaying simple jog buttons, and “load pattern” and go buttons …

Presumably I’d have to attach some kind of screen / interface if I migrate to other controlling software ?

Anyone else tried to “upgrade” one of these ?

Did you try the trial version of Lightburn and see if it works?

Assume this is the one you found… looks like the same animal…

If it connects, go to machine settings and save a copy, just in case… if you can access it and get the configuration it may save you a headache down the road.

Good luck


Thank you so much! Looks like you may well have identified it- the picture of the cream box looks identical.

I haven’t tried the trial version - but that sounds a cracking idea and allows me to see if it’s going to work prior to shelling out a whole load of cash which would cut my Gordian knot.

What you’ve posted looks very similar to what I found from
Memory in regards it’s model number (odd that one letter is different in the model number on the sticker … but hey … It
Won’t matter if it works !) and obv I don’t have that touch interface - but I guess if the software connects then I should be able to buy the touch interface and I’ll be away :slight_smile:

Looks like some simple homework next week when I take my laptop in to meet up with it.

Have these controllers been sold for over 10 years ? I’m not familiar with the laser cutting industry - but in most industries motion control boards etc seem to have a commercial life of just 2-3 years before the next model comes along … so I’m amazed if a plug for plug replacement is still being sold but if so it also implies I’ve lucked out if my controller ever goes bang too…

As I say - thank you !

Let us know how it works…

Lightburn generally supports Ruida controller, so for free it’s worth a shot :wink:

Good luck, we’ll be waiting to hear from you…


1 Like

Well ! It works !! (Sort of). A kind person from here (Mark you know who you are - thank you!) emailed over Rd works v8.0 installation files, and potential passwords - and I gave that a go. First the “sort of” bit …

My laser cutter is connected via usb.

Strangely when I try rd8888 or RD8888 as the vendor password in Rd works - it seems happy, but when I click on the “read” button - when trying to get the vendor data- after a few seconds it complains “no connected device”.

If I close and restart reworks, and try other passwords eg hd8888 it immediately complains password incorrect, so I presume the password as Rd8888 was correct but something else funny is/ was going on.

(I did install the usb driver from Rd works).

BUT this is probably moot - as I fired up lightburn in trial version and it connected !!

I jogged And shuttled the laser cutting head around, from within lightburn, and was able to read the machine data from it (which all makes sense eg size of bed) .

It gave me two possibilities -
¡Ruida unrecognized (601mm & 401mmi al A4008 For IDSP Connection Packet/USB


Ruida unrecognized (601mm x 401mmi at COM3
Which I went for which seemed to work well - it could read the machine settings and having configured the origin as top left - I could jog the head around fine.

I haven’t tried cutting anything yet as didn’t have time - and I’m wanting to finish tidying up the computer - including making a backup of the hard drive so if I make a Horlicks of things I have an escape plan - and upgrading windows 7 to windows 10, then I’ll sit through some lightburn videos and get a feel for how that works.

One slight snag is my machine has an lcd touch screen (a Lilliput 7 inch monitor) which was driven by the proprietary aPS-Ethos software it came with which seemed to drive it as a second monitor to the computer, to “synthesise” jog buttons, and “load / run” buttons - but this is clearly not a ruida HMi panel.

I see ruida / cloud ray panels go for £70 ish on Ali express so wonder if I should buy one.

If I’m going to
Migrate to light burn do I really need a controller panel on the front of the laser cutter ? is everything functional without it just using mouse and keyboard on the computer ? Or indeed can I use some kind of software hack to use my Lilliput 7 inch touch lcd monitor instead ?

Thanks everyone for getting me this far …

Mine doesn’t give me a disconnected message… but

If I want to talk to the Ruida, it has to be in an idle state for good communications… seems like communications are about it’s lowest priority … ensure you’ve backed out of any data entry menus of the Ruida before trying to talk to it…

If it doesn’t complain, then it’s probably the correct password…

I don’t think they are like terminals… and I would think everything you would need should be on your console? I didn’t see a photo of it…

The connection on my Ruida is not like the db-25 in your controllers photo… so it’s likely not to be a plug and play hardware wise… I’d be surprised if it would work at all.

If you want to implement user origin with your software, you need a machine panel. The only way to set the user origin is via the machine panel. I use this most of the time…


1 Like

Thank you !

I’ve sent a message to cloud ray to see if they can advise on suitable panels. Will report back what I find to help anyone reading this thread in the future.

I think without the panel bug hunting is going to prove awkward.

I have managed to move forwards -

As now I’ve got lightburn to turn the laser on, move following a (simple) design of a circle - but can only get it to lightly mark a piece of paper and not cut it even when told to move at 100 power , 1mm / sec (this is a 30W co2 laser -
So clearly something odd is happening - and I think I’m still at the stage of thinking it must be a software level problem …)

I guess I ought to be seeing if there’s a firmware upgrade for the controller too - but that is proving difficult to find by googling. From what I read people find out if there are firrmware upgrades by contacting cloud ray or ruida directly rather than simply looking at a web site with the latest drivers which seems weird. Is that so ?

Generally not recommended to run co2 tubes at 100%. If you need to run at 100% you should have purchased a more powerful machine.

  1. properly working tube
  2. clean and aligned optics
  3. proper focus

If you have these three, they work…

Which one are you missing?


1 Like

Could this run at the Ruida low-speed / low-power limit, where motions below the Start speed use the laser tube’s overall Min power setting?

If so, then more speed = more powah!

If it’s pretty much already scrap, then ya got nothin’ to lose.

That said, enough cases of badly misconfigured Ruida controllers have washed up on the shores around here to suggest devoting plenty of time to pondering the existing settings and figuring out why they might be totally wrong, as opposed to believing they’re High Truth™ set by somebody who knew what he (it’s always a he, in those cases) was doing. :grin:

1 Like

Ahhhhh interesting ! I bet that’s what was happening - as going faster - inexplicably; it’s started hurting through paper :wink:

Grasshopper will go and play some more and report back - thank you.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.