TT-20 Pro ALARM:2 G-code motion target exceeds machine travel

G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)
On or near line 0:
Job halted

I have tried Soooo many options for this , it has worked only once when i first got it , and now Nothing, I have tried to change $10=1 to $10=0
not sure I’ve even done that right since nothing has changed, I’d really like to use the Machine i’m thinking it’s out of date


Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.
Grbl 1.1h [‘$’ for help]
[MSG:‘$H’|‘$X’ to unlock]
[MSG:Caution: Unlocked]

Hi Tre,

Alarm 2 are for the most part issue based on coordinates.

a) What Start from have you selected. Absolute coordinates?

b) in console type
press ente
press enter

Send output please.

yes i have before


Either X or Y are incorrect on steps per mm

Isyour TTS only 300x300?

I would suggest a firmware reset
Press enter

ok i’ll try the reset, I also think i’m not changing the settings correctly, since i have not seen the $10=1 change at all

Are you seeeking to have your steppers to “HOLD”?
If so $1=255 in console.

You can also change them on EDIT > Machine settings.
Just dont forget to write.

[MSG:WiFi reset done]
[MSG:Settings reset done]
[MSG:Position offsets reset done]

Ok now power cycle the machine, off > On

What Start From are you using, absolute coordenates?

My apologies as I am very new , and i’m not sure what (steppers are ) but i do get the same errors over and over

Its ok! :slight_smile:
Stepper are the motors that move your machine

If you post a screenshot of LightBurn, what we want to check is:
In the laser panel, below “START” button. theres a “start from”: dropdown.
What setting is there. Absolute coordinates?

yes as of right now it will be on absolute coordinates

OK great,
Now open this file and just try to engrave it on a little bit of cardboard or spare wood
Dot Test with Angle.lbrn (46.3 KB)

If possible, post a picture of the output

i’m here now , with these new settings,
[MSG:Local access point Laser_53289 started,]
[MSG:HTTP Started]
[MSG:TELNET Started 8080]
Target buffer size found
[MSG:Using machine:MKS DLC32]
[MSG:Mode=STA:SSID=:Status=Not connected:IP=]

should i try the file with these settings, and my laser is positioned to the back left corner

I am not sure where the TTS homes, but usually is front/left.

Where are your switches located?

And yes you can start the test file without changing the settings for power/Speed

I don’t have any homing switches , this Machine didn’t come with any but I was thinking about ordering them

Project loaded in 2 milliseconds
Starting stream
Job halted
Stream completed in 0:00
Grbl 1.1h [‘$’ for help]

You will have to tell me what the machine did.

Stoped withotu even trying to move?

correct it didn’t move at all , but no errors this time :slight_smile:

Well thats not good!

Unplug the laser head cable if you can, just so we test only motions.
Repeat the run. Same behavior?