Turning laser off between cuts

I have made a test file with three elements. An outline square, a welded polygon and a circle.

All three elements have different cut/scan characteristics, and all cut/scan exactly as expected using PWM called by M4 and Sxxx

If run individually, all is good.

However, if I just send start command, there is no S0 added between each element, so the laser is left in the ‘on’ state whilst traversing, causing an unwanted burn line between elements.

Do I have to tell it somehow to turn off the laser or set power to S0 between cuts?

screen grab of setup

Check your setting for $30 and $32 in the console by typing $$ and pressing enter.

$32 should be 1 (enable laser mode)

$30 should be 1000

The $30 value can be set either in your firmware to match LightBurn, or in the LightBurn device settings (S Max) to match your GRBL setting.

thanks for input, grbl setup is


Max in Lightburn is also 255

I’m using Larry M’s 1.0c for laser firmware on the controller

each cut burns individually at the correct power, it’s the not turning laser off between the tree separate cuts that is the issue

If the controller is running is “laser mode” it doesn’t need S0 commands, as G0 moves are non-cutting moves. If you’re using the generic LightBurn GRBL device profile with a firmware older than 1.1f you’ll need to switch to using GRBL-M3, which generates significantly more verbose GCode, but should do what you need.

Thanks, will flash firmware up to 1.1f