Two Diode Lasers will not Fire when clinking Start

Two diode lasers, xTool D1 10 w and TwoTrees TS2 will not fire the laser when I click Start. Both move to the starting point and then nothing. I have uninstalled and reinstalled Lightburn and restarted Win 11 PC. Updated to latest version and still neither are working. Anyone else facing this issue??

Curious that you’d have the same issue with both lasers. Possibly a common problem.

Let’s address one at a time. Start with the TwoTrees.

Can you provide the following:

  1. Full screenshot of LightBurn with your design, Laser window, and Cut window in view
  2. Click Devices button in Laser window, then click once on the name of your laser, take a screenshot
  3. Screenshot of Edit->Device Settings
1 Like

I have collected them. Here they are.

I just tested this on my CO2 30 watt and Fiber 30 watt galvos and getting the same thing. Lightburn, what has happened?? Two different PCs, 4 different lasers all having the same issue.

I suspect something in your local conditions if this is the case. Is there any physical commonality between the 4 lasers?

Or these could all just be separate issues.

As for the TwoTrees I don’t see anything obviously wrong in the screenshots.

Can you detail out exactly what happens when you attempt to burn?

Also, please provide the following:

  1. anything in Console when this occurs
  2. screenshot of Preview for the design
  3. Save GCode and save with .txt extension

Nothing has changed. I ran LB 3 days ago just fine. Last night and again today. LB does not want to fire. I have emailed support as well as posted on FB to see if other have had similar issues and Jason Dorie recommended a log file to be sent on the support ticket.

I did see error code 22 on the console 1 time, but after a few times I did not see it again. This is super strange that 2 PCs and 4 lasers all do not want to fire.

Here is a more detailed explanation as to what is happening.

I was using my xTool D1 to cut an image. I have user LB to do other testing and not had any issues. I am running Windows 11, latest update. LB, 1.2.01. Firmware on D1 is up to date.

I added my very basic outline image and even tried just a square drawn in LB and when I click Start, the laser head moves to home, per my setting I selected for that and nothing happens. No laser beam even starts.

I change out machines to a brand new TwoTrees TS2. Same result. I then switched out the USB cable, same thing. On the xTool, it has Wi-Fi and tried that, same result. I uninstalled LB, restarted PC and reinstalled. 1.2.00 and same thing.

Updated LB to 1.2.01 and same thing.

This morning I went out to my Galvo lasers in my shop. Different PC, Windows 11. CO2 30 watt Galvo, I was a BETA tester and it work GREAT! Today, same as above, nothing happens. Tried my 30 watt Fiber Galvo and guess what, same thing. Nothing happens.

I now have to use Laserbox for the xTool, garbage software. LaserGrbl for the TwoTrees and EXCRAP for Galvos.

xTool often has connection issues which is why I thought to start with TwoTrees. The fact that LaserGRBL is connecting and works is interesting.

You’re saying EZCad works on the Galvos now? Did you swap drivers?

Do you have any Anti-virus software running on the machines? I’m curious if they’re blocking LightBurn from accessing USB or something else similar.

What does show in Console? Let’s stick to TwoTrees for now.

Excad has worked fine. I did not run it today. The Galvos are in my shop and my diodes in my house.
I will go run the TwoTrees one again and take screenshots of the console screen.

Clicked Start test 2
clicked Start
Turned on Laser
simple square gcode.txt (174 Bytes)

I also disabled Norton Anti-Virus and Firewall when I did this last test and I am seeing that some people have reported issues with that.

The g-code is malformed. There is nothing resembling a square in the g-code so curious what’s going on. I have never seen LightBurn generate bad g-code in terms of core content. It seems as though there are no objects or layers that are considered for output.

What does Preview look like?

; LightBurn 1.2.01
; GRBL device profile, absolute coords
; Bounds: X0 Y0 to X0 Y0
G00 G17 G40 G21 G54
G1 S0
; return to user-defined finish pos
G0 X0 Y0

Let’s see that your laser and communication is basically functioning. Can you run this g-code file? It should be a similar square with very low power.

square.txt (259 Bytes)

Does the machine move and fire?

The preview is not right. It should be black. I did a fill on my square and still the preview is not showing proper.

When I ran your gcode, it worked!!!

This tells me it’s not an issue with core communication and laser function. There’s something not functioning correctly with your install.

Do you have any Anti-virus software or anything else that could be affecting the runtime function of LightBurn or possibly impacting the installation?

If so, please disable and retest. If that doesn’t work, then try reinstalling without AV running.

I do have Norton installed on both PCs. I disabled Anti-virus and Smart Firewall to run the tests. I will uninstall norton and LB, reboot and install LB only to see if that is the issue. That will take some time… :expressionless:

Uninstalled Norton, rebooted. Uninstalled LB, rebooted. Installed clean 1.2.01 and same issue persists. :frowning: LaserGrbl is not having this issue, but it is not LB.

Try this:

  1. File->Open prefs folder
  2. Close LightBurn
  3. Delete all contents of prefs folder
  4. Restart LightBurn
  5. Reinstall devices

Note that you will lose ALL devices and configurations if you do this. You may want to take a backup of prefs, export devices, etc. if you don’t want to recreate them.

Well Hot Dog!!! That seemed to be the trick. Jason said that I had “turned off the “Output sub layer” toggle switch on the only layer in his project.
The fact that it behaved identically across four different machines strongly indicated an incorrect cut setting, not a software bug.
I’ve updated the code so it’s not possible to get it into this state any more.”

It still does not explain the Galvos, that are on a different PC, different install and different preferences of LB that the diode PC. I will keep troubleshooting those machines.

If you are transferring files then the cut settings would follow the design which could account for that.

Your screenshot didn’t indicate a multi-layer cut setting unless I’m missing something.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.