TwoTrees TTS-55 Connection Issues with Lighburn GRBL

Hello Guys,

i’am new in the laser business and i’m trying to connect my Two Trees TTS-55 with the Lighburn Software, but it is’nt successful.

I’m getting this out of the console, but i don’t know what that means:

Waiting for connection…
Waiting for connection…
Waiting for connection…
[MSG:Local access point Laser_ started,]
[MSG:HTTP Started]
[MSG:TELNET Started 8080]
[MSG:‘$H’|‘$X’ to unlock]
Grbl 1.1 [‘$’ for help]
Your Grbl may not support Variable Power mode (M4)
If your laser does not turn off between cuts,
switch to the GRBL-M3 device
[MSG:‘$H’|‘$X’ to unlock]
[MSG:Caution: Unlocked]
Waiting for connection…
entry 0x400806a8

When i connect the Laser with LaserGRBL everything works fine. The Baudrate is set to 115200 and thats the same as in LaserGRBL.

There is a .lbset with configuration for the TTS, but i dont know how to load it.

Is there anybody who can help me?

Thanks a lot.

To me the output looks more like a firmware issue, but then LaserGRBL also shouldn’t be able to connect successfully. Can you move the laser using LaserGRBL?

While tackling another problem, we found a solution to change the “enable DTR signal” option in device settings to make the connection work properly. You might try this as well.

I can move the laser with LaserGRBL properly and homing is also working fine with my self added limit switches in LaserGRBL

Thanks Melvin!
I enabled DTR and now its working!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.