Ubuntu, can see BJJCZ USBLMCV4 connection - Lightburn has auto and "PORT #: 9"?

Just put together the new fiber… Can’t seem to get Lightburn to see it… It does not automatically find it… Had to use manual device creation.

I can see the fiber driver is connected…


Bus 003 Device 019: ID 9588:9899 BJJCZ USBLMCV4


[1062165.203224] usb 3-1: new high-speed USB device number 19 using xhci_hcd
[1062165.351792] usb 3-1: New USB device found, idVendor=9588, idProduct=9899, bcdDevice= 0.05
[1062165.351797] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[1062165.351798] usb 3-1: Product: USBLMCV4
[1062165.351799] usb 3-1: Manufacturer: BJJCZ
[1062165.351800] usb 3-1: SerialNumber: xxxxxxxx

The only options for the connections in Lightburn are Auto and PORT #:9 Which I’ve never seen before…

I don’t see an entry in the /dev/ directory, especially a numeric one. I imported the values from the Cloud Ray dongle from markcfg7… it almost looks like a com port from windows…

Any suggestions?

EDIT… must be a driver issue, the spouses Windows machine finds it ok… Anyone know which driver it’s supposed to use?


Have you seen this? This might be related to what you’re seeing.

LightBurn & Galvos - LightBurn Software Documentation

I tried that with the first information I got from lsusb… Still can’t find a device ‘file’…

Will double check… maybe I hosed it up…

Edit: Didn’t reload udev :sob:

Seems to work now…