Ubuntu Mate 22.04 and TwoTrees Totem S can't connect

Hello people ! I need help. Since 3 months I have not used my Laser device (TwoTrees Totem S). It worked fine. Now after some Ubuntu update for the last 22.04 and also for Lightburn, Lightburn can’t connect to my Totem S, I do not know why ! Must I have to update GRBL or a driver ? Any idea please ?
I have read the related topics and find this one : No connection to Lightburn after upgrading to Ubuntu 22.04

My lsusb command gives : Bus 001 Device 042: ID 1a86:7523 QinHeng Electronics CH340 serial converter
Then the dmesg command : échec de lecture du tampon de noyau: Opération non permise

Then : grep -riIn “1a86:7523” /usr/lib/udev/rules.d/* = Nothing

Is your user a member of the dialout group? And do you already have the udev modifications setup? Sometimes running in root will work…

You don’t need an entry in udev, it will default to something like ttyUSBn (n is a number), ttyACMn or something like that…

Do you have a new usb device shown in the laser window after you plug it in?

Use this…

ls -l tty[US]*

This is two invocations of the ls -l command

crw-rw---- 1 root dialout 4, 72 Nov  1 06:22 ttyS8
crw-rw---- 1 root dialout 4, 73 Nov  1 06:22 ttyS9
jack@Kilo:/dev$ ls -l tty[US]*
crw-rw----  1 root dialout   4, 64 Nov  3 10:44 ttyS0
crw-rw----  1 root dialout   4, 65 Nov  1 06:22 ttyS1
crw-rw----  1 root dialout   4, 73 Nov  1 06:22 ttyS9
crw-rw----+ 1 root dialout 188,  1 Nov  3 12:12 ttyUSB1

The first with no laser plugged in and the 2nd one after I plugged it in, ttyUSB1 shows up … that is my laser. Sometimes they ‘persist’ awhile and you remove it and re-plug it, you might see something like ttyUSB0, ttyUSB1…
Select this for your laser in the laser window.

Does it say ‘Ready’ in the top left of the laser window?


could be due to the brltty grabbing /dev/ttyUSB0 as noted and solved in this posting:

Thank you very much for all of you. It helps a lot. :blush: :partying_face: :pray:
In the last link from DougL, I tried the last comment :

Unless you are using a braille display this should do the trick:
sudo apt remove brltty
Don’t forget to plug your dongle off and on.

I like simple things, and it worked for me. Now my laser device works nice except this in the LightBurn console (but I can use le laser without problem anyway) :
Capture du 2022-11-04 13-51-58
What do you think about that = error:9 G-code locked during the alarm state or the step by step advance ?


homing cycle error… maybe an endstop switch is bad or the firmware isn’t setup correctly to home to the switches. Move your laser head to the middle of the machine and hit the HOME button in LightBurn and see if it homes properly.

Hello DougL. Homing works nice. My laser device haven’t any endstop switch, I just set the working aera to 30 by 30 cm and it works good.

If you enter $$ in the LightBurn console tab you should see it spit out the GRBL settings. With no switches you will likely see $22=1 which says that it should Home the machine to switches but with no switches then $22 should be set to 0.

1 Like

Yes that’s right, the console given me $22=1
How to set $22 for 0 ?

Here is my result of the command $$ :


type in “$22=0” will set it to 0 which is no homing

1 Like

Yes. This is the setting needed when endstops or limit-switches are not present.

You will also want to switch off the Auto-homing on start up.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.