Ubuntu: Port failed to open - already in use?

I have a KentokTool LE400Pro that I’ve been using with LightBurn now for a few weeks on Ubuntu 20 with no major problems.

Just plugged it into my laptop today, and suddenly it’s unable to connect. Laser cutter is turned on. USB plug is good. But the console just gives me an endless series of:

Waiting for connection...
Project loaded in 272 milliseconds
Waiting for connection...
Waiting for connection...
Port failed to open - already in use?
Waiting for connection...

My laptop has two USB ports, and I tried both. Tried updating all packages and rebooting. No change.

Why is LightBurn suddenly unable to connect to my laser cutter?

Ok, not sure how I fixed it, but this is what I did.

With the laser cutter plugged in and turned out, with LightBurn running, I unplugged the USB cord until the ttyUSBx disappeared from the dropdown next to the “Devices” button. Then I clicked Devices and selected GRBL. Then I turned my laser cutter back on and waiting until the ttyUSBx reappeared. Then it automatically started responding and went to home.

If you had a new USB device plugged into a USB port, the computer may have assigned the port that LightBurn was using to the new device.

If this happens again, open the Laser window, select the bottom middle box and if optional devices are offered, select another USB port to test.

I had unplugged it, but I plugged it into the same port as before. Before I plugged it in, no port was shown, and the port it was in showed up, but even after selecting that, it gave me that error.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.