UI Text is Too Small in LightBurn on High-Resolution Displays - Solution Included

Hi everyone,

I recently faced an issue with the LightBurn software where the UI text was too small to read on my high-resolution display.

After some troubleshooting I found a solution that worked perfectly. I’m sharing it here to help others who might encounter the same problem.

The problem is my high-resolution Windows screen. To be able to make everything on my PC more readable I have the layout scaling set to 200%.
However, when I opened LightBurn, the UI and text appeared extremely small and unreadable.

The solution for this problem requires some tweaking of Ligthburn.exe executable settings. These steps leverage Windows’ ability to handle DPI scaling on a per-application basis, ensuring that LightBurn’s interface is more readable on high-resolution displays.

  1. Find the LightBurn application executable (LightBurn.exe). This is usually located in the folder where you installed LightBurn, such as C:\Program Files\LightBurn.

  2. Right-click on the LightBurn.exe file and select Properties. > Go to the Compatibility tab. > Click on the Change high DPI settings button.

  3. In the window that opens, check the box labeled Override high DPI scaling behavior. In the dropdown menu under Scaling performed by:, select System (Enhanced).

  4. Click OK to close the DPI settings window. and Click Apply and then OK to close the Properties window.

  5. Lastly Restart LightBurn

I hope this helps anyone struggling with the same issue. Feel free to ask any questions if you need further assistance.

Best,

Keith

4 Likes

Did you try those settings? It worked fine for me on a high-resolution Surface Pro screen.
grafik

Your approach is also explained here:

2 Likes

I still have not found a scaling that lets me use my PC normally without the camera getting all glitched out.

It seems I have to change my resolution to be able to use the program.

Thank you for taking the time to reply. Would the visual aspect of the UI have any effect on the camera settings? It shouldn’t right? I will probably end up getting a low resolution monitor for my shop or installing a stand alone PC I can remote into.

At 57 seconds in the video the camera UI is way off. I think I just got the settings dialed in now somehow hopefully it stays where it is at.

I don’t think the UI should have any effect on the camera settings. I saw in your screencast that you used “custom capture system” in main LB settings. Try to set it to “default capture system” and check if it works better. I don’t know, but worth a try.