Unable to connect to Ruida 644XG after 1.4 (possibly 1.3 as well)

Laser was brought down a couple of weeks for maintenance and installing powered Z axis/ autofocus. Upon opening Lightburn, I was prompted to download latest update (1.4). Lightburn was showing disconnected, which isn’t out of the ordinary because it usually does until I make it do something and it changes to connected. I went over to ‘machine settings’ and got the ‘communication with controller failed’ notice.
Windows is making the sound when I plug and unplug the USB. I restarted Windows and opened LB back up and got the same thing. I swapped with all USB devices to try different ports, I changed the usb cable going to the laser, I plugged it directly into the controller. My previous Ruida setting was still listed Devices > Auto > Ruida644XG
I opened devices and that entry is the only one in there, listed as *Ruida 644XG
I tried ‘find my laser’ but it came back with nothing. I tried removing that entry and manually adding it, but got the same. I reinstalled LB, both on the original drive of D and then later after uninstalling and removing any remaining LB files on the main drive, C:\ I chose to install the FTD option (don’t remember exactly what it is called, but the first radio button after installing LB in the same list as show change log) each time I did reinstall LB. My camera will load into LB every time I open LB or plug in the camera with no issues. The laser itself starts up like I would expect it to. I have tried powering it off and on, jogging the laser around, and resetting it at the panel.
I’m not sure exactly where to go from here with troubleshooting. I appreciate any help very much!

In Windows you should be able to see the laser in the device manager. If you can not do this, Lightburn will not find it.

Did Windows do an update? Sometimes this can change drivers, which is what the symptoms indicate.

This just means it’s not talking to the controller… if it isn’t connected you will get this…


Sounds like we have the same animal. I lasted less than a week using usb. Went to direct connect via Ethernet … then purchased a $12 wireless bridge that allows it to connect to my lan.

No more driver issues… :partying_face:

Lightburn came out with the Lightburn Bridge. I had a PI laying around so I used it… better than the $12 bridge…

It’s worth the effort to Ethernet it over usbing it…

:smile_cat:

It is showing up in device manager as a USB composite device. Could you link me the wireless bridge you got that is doing the trick? Thanks, I really appreciate it!

I meant to mention that I did try briefly with the ethernet and I was trying that directly into the controller as well. I used the IP # shown in the control panel, but my ethernet game is not what it once was, so I’m sure that’s just due to my ignorance and not any kind of machine issue. I also currently have only 1 ethernet port in my computer, so I’d have to get a bridge anyway. Thanks again!

If you have an unused wireless router laying around, check it to see if you can configure it as a bridge and just use that.


This one doesn’t say it’s a bridge, but usually a wireless extender is the same animal… I think I’d ask before I purchased it…

This might also work… it plugs directly into an outlet…

These are not laser specific, just normal Ethernet stuff…


A quick review of tcp/ip or your addresses on your lan… probably a better definition is dhcp/ip…

When you computer plugs into a network, it has no clue as to what addresses are there… it sends a query, usually to your router, for an ip address. The router returns a valid ip from it’s pool to the pc so it can have a unique ip address for routing. The mechanism (or software) is DHCP.

DHCP is the software protocol that issues addresses. In most homes, this software resides and executes within the router, but it needn’t be.

The Ruida does not have a dhcp software running on it so can’t give your pc an IP address… so it’s dead in the water, so to speak.

I used this, but I have an extra Ethernet port that is separate and I can change it’s ip to whatever I wish… I put it on the same domain as the Ruida, 10.0.3.x and it ran fine…

The Ruida has it’s ip set by the user on the machines console and cannot be changed via software, that we are aware of. This is known as a static address, one that doesn’t change.

Most routers will allow you to bind a MAC address with an ip address so it’s dhcp server won’t issue the same address to another device…

Make sense?

Good luck

:smile_cat:

Do you think this would work?

I have one of these available.

I would think so, what seems to be the issue?

:smile_cat:

It’s currently providing internet for my PC. I need a low latency connection for my PC so I use that device and plug it into my ethernet port and that has been working ok. I found a couple of old routers (which may work if I can find the power cords for them) plus one that was my last modem. I tried using that last one first but ran into a problem since some documentation I read said that wireless bridge mode must be enabled, as distinct from ‘bridge mode’. Well bridge mode is easy to find, but I could not find anything about wireless bridge mode. Does the bridge vs wireless bridge mode seem legit to you?

I’d suspect they are the same…

The only other kind of bridge for lan operations is to bridge from one network domain to another…

Set it up for whatever bridge type mode it has and see if it works… best way…

Good luck

:smile_cat:

After a few hours of fighting with routers and ethernet stuff, I plugged it into my laptop which was still running 1.3.01 and it works just fine.
Thanks again for the help!

What did you do? Go wireless bridge?

:smile_cat:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.