Unable to get 4th Axis Rotary working in Lightburn

Hi I can’t get Rotary working with Lightburn 1.4. We have replaced the controller with another for the 6550 PRO and still get the same result. I have tried getting it to work with 3 different rotaries, Yorahome 4th Axis chuck, Yorahome TLC roller and Shapeko Roller and they still do not work. I have gone through the Rotary setup in Lightburn and nothing rotates when using the test button. Nor does anything move with them when selecting the Y axis in the MOVE window even though 10mm or 100mm is selected to move. The Rotary selector switch is in the correct position on the controller and have also tried in the normal position.
Hope someone can help
Also wondering if I can switch to an earlier version of Lightburn to confirm it is not 1.4 causing the problem. All hardware is new.

There was one engraver that needed new firmware when enabling the rotary… but it’s not this one.

This video recommends using the Y axis for the ‘Fourth Axis’.

If your control board is the same as the one in the video, you have three stepper motor drivers. I can’t tell from the brief pic if they’re X,Y,Z or X, Y1, Y2.
In LightBurn, in the Console window request the Machine Settings by typing the Following:
then press Enter.

Please scroll back to the beginning of the text in the Console window and Select and copy the whole report, and paste it into a reply here.

Some firmware is 5 axis but with only three driver chips on board I can’t see how a ‘fourth axis’ is available (other than using the Y axis)

If you do plug the rotary into the Y-axis, does the stepper motor get warm or buzz?

Thanks for getting back to me John see capture below for GRBL settings when connected to 4th axis chuck. With the Yorahome 6550 PRO there is a separate connection for the rotary and a switch on the controller for selecting the connection which cuts out the Y1 & Y2 or revert back to standard. We thought it might have been the controller and Yorahome kindly sent me another but has made no difference when working with Lightburn 1.4





















































This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.