Unable to import .ai or .svg files

I’m using Lightburn 1.4.00 with the grbl license.
My machine is an Ortur Laser Master Pro 2. I’m unable to import vector files, .ai or .svg. I’m able to import these files in other programs, specifically easel. Here is my step-by-step process and the results that I get.
I click on File>import> then I choose my .ai or .svg file and the “Import a File” screen just disappears. I also can’t drag and drop a .ai or .svg file.

Of note, png files will import without issue. I’ve attached a .svg file that I’ve been trying to import.

Thanks for the support,


I am not seeing the .svg file, it may be that the forum rules don’t allow it, to get around this try again but include .txt to the end of the filename

Here is another attempt to upload the .svg.


There seems not to be a stroke defined on the shapes in the SVG. Try importin
g this.


That worked! How/what did you do to achieve that?

For graphic editing and selection I’ve been using my old version 7 of Photoshop, selecting a section, making a path, then exporting the path to illustrator as an .ai. Then I’d have to convert the .ai file to .svg using an online conversion site. This has worked with easel online for my desktop cnc, which is perplexing.


Different software developers handle file formats in different ways. Not every developer follows exactly the format of the original file. What works between two packages might fail with a third. Import and export are both suspect. You might be amazed to learn how many dialects of PDF there are out there.

You can open the SVG file in a text editor, and replace all that contain stroke:none with stroke:red and save.

1 Like

I did this in Inkscape but if you’re going into AI you could simply set the stroke there. I believe AI has native SVG export so don’t think you’d have to convert to SVG externally unless the version simply doesn’t support it. Note that LightBurn also imports AI files natively so SVG conversion isn’t required.

Awesome! Thanks. It worked after switching all the “stroke:none” to “stroke:red” in notepad text editor just like you suggested.

I think I’ll have to switch to inkscape for future projects to avoid any more hassle.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.