Unable to increase Bed Working Area size - ALARM:2 error message


New Lightburn user after upgrading the controller board in my K40 to a Monport GRBL V2 Controller.

Having problems setting the correct bed working size. When I first added the device I just left the default width=300mm and height=200mm setting, but that’s not quite big enough for my bed.

So I went into Device Settings and changed the working size to width=310mm and height=210mm - probably not accurate and needs to be bigger, but was starting with small increments to work out the correct values.

However when I use the move window and move anywhere over 300mm on the X axis or 200mm on the Y axis I get an ALARM:2 error message as follows:

Starting stream
G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)
On or near line 0:
Stream completed in 0:00
[MSG:Reset to continue]
Grbl 1.1f [‘$’ for help]
[MSG:‘$H’|‘$X’ to unlock]
[MSG:Caution: Unlocked]

I’ve made sure I’m in Absolute Coordinates mode and everything seems to be homing OK. Here is the console immediately after bootup and homing:

Waiting for connection…
Target buffer size found
Grbl 1.1f [‘$’ for help]

Also “Get Position” shows all 0.00 values for X/Y/Z after homing.

Am I missing something? New to Lightburn so not really sure if I’m following the correct steps, but I thought changing the working size in Device Settings would be the correct way to increase the bed size available.

BTW: Laser jobs are running fine using Lightburn, just with a restricted working area size of 300x200mm.

Here is a screenshot of my Device Settings:

Thanks for any advice.

Did it previously work with 300x200 or 310x210?
I think K40´s are 300x200…

Yes, it runs fine with Lightburn with bed size of 300x200, I ran a few tests and all OK.

Only thing is a small portion of my accessible bed is unusable.

Even when I increase the working area size in device settings it still works OK, until you try and travel to x:301 or y:201 and then the error message.

I have changed the bed in my K40, and although not much bigger than the default 300x200, I would like to get it setup in Lightburn to be able to use the full size bed.


Maybe it may not be advisable to change the dimensions.
Type $$ in console and copy/paste here the result.

Here is the result of $$:


Thanks for your help.

Keep your workarea (310x210) in Lightburn type in console $130=310 enter and $131=210 enter, but do some tests first, because the speed of laser engraving/cutting is usually higher than jogging in the move window.

1 Like

Perfect - thanks for your help.

Actually was just twigging after seeing the 300 and 200 max limits in the $$ command you got me to run that changing Device settings hadn’t changed the firmware settings, so it seems Device Settings is for the work area shown in lightburn and have to also change it in Machine Settings or via the console.

Thanks for the clues and taking pity on a Lightburn newbie.

Have a great day.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.