Unable to successfully frame a project

I have been successfully using LIGHTBURN with my 60W OMTECH for about 7 months. This morning I am unable to FRAME before starting a project. The head wants to go to the top, stop and bounce/chatter until I hit the red control switch. Any thoughts on a resolution?
With thanks!!

When does it do this? During homing? If so likely an issue with the Y-min limit switch. Check for proper operation.

This issue occurs each time i attempt to frame my projects and each time I attempt to cut and or engrave.

He stated he was ‘framing’ so I have a assume it probably had to boot properly, at least that morning.

I’ve changed to ‘inches’, but the rest of the art was in mm. When I frame it, it runs to the end of the axes and stops.

If you overrun it, a Ruida should stop at the ‘end’ of that axes. It shouldn’t ‘strike it’.

At boot, if it ‘runs’ away, press the ‘esc’ key.

It will stop the home operation and leave power on so you can read/use the console.

if it doesn’t home, the display will show x and y values of 10000

Use the console Z/U → Diagnostics and it will show the status of the limit switch. With it idling you can place a Ferris object, like a screwdriver on the sensor and see if it changes state on the machines console. I’m making the Y limit active here.

I made a quick video, maybe that will help.

Good luck…

THANKS for the idea!!!

Might want to check out the video…


This seems odd.

You’re saying the machine homes properly indicating that the limit switches are working for homing. But yet you’re getting a collision when trying to frame or engrave? The switches should prevent that second scenario from happening.

In either case you may have a couple issues going on:

  1. something causing framing to go beyond expected location
  2. malfunction of limit behavior under certain circumstances

Did you recently update LightBurn? What “Start from” mode are you using in Laser window?

Don’t quite follow you here. If it’s homing it should not crash?


Meant more generally that the switches would need to be working for homing to work. And if switches were working they should also prevent crashes at that limit.

You are confusing home and limit switches. The Ruida only uses the ‘-’ input or home switches to determine it’s home position. They are ignored after a successful home.

You can trigger them while it’s running and it’s ignored.

The Ruida does have limit switches and are connected to the ‘+’ input …

The green are the limit and the red are the home switches…

This is the layout for using them… same color scheme

Make sense?

It has it’s drawbacks, which is why you don’t see them on most of these low cost machines.

  1. lose work area as the head must be able to move outside the ‘work area’ to make the limit active.
  2. instead of 2 switches, you need 6.


Ah. Didn’t realize this was the case. That seems a waste.

To me both scenarios are limit switches. Just min or max value limits.

Do you know the rationale for respecting max limit but not min limit? At first blush I don’t see why these would be treated differently.

It requires a switch at each end of each axes. If the head goes outside of the workspace in any direction these will become active. So it does limit both max and min of each axes.

If the head on there was $40k, you might look at it differently. It’s totally for machine protection. That’s why we don’t see them used very often. Mainly because of loss of work area … same size machine, smaller workspace… There’s a relatively low chance of this crashing, I would think. Not worth the cost for us…

I’ve seen the configuration of them somewhere in the Ruida, I think it’s in the machine settings of Lightburn…

I’m not an EE but I know a little about dsp hardware. It resembles ‘hardware’ more than most of us think of, so this operation doesn’t surprise me… I’m sure it was designed that way.

Same reasoning that the pwm is started as soon as you press ‘start’ (on the console) and runs continuously. Lps are designed for two control signals, IN for power (pwm from Ruida, ‘pot’ on a K40) and L (laser enable on the Ruida, pwm from a K40 controller).


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.