Unexpected Travel

I am using a Jtech 7W photonics laser mounted to a new Shapeoko 3 XXL CNC running GRBL 1.1f firmware. I just recently upgraded my Lightburn software from 0.9.7 to the latest 0.9.9 and now having issues with the system travel upon completion of a burn or if I click on Go To Origin.

I can home the machine just fine, move the laser to the center (origin) of the job, will click on Clear Origin and Set Origin which I assume should me the origin at that particular spot., yet when the job finishes or if I click on go to origin, the system then drives fast and hard to the machines front left corner and keeps on grinding away with no end in sight until I hit the emergency stop.

I do have changed my $10 value to be $10=0 which worked in the previous version of the software, but now it is NOT working in the latest version. Any ideas what I need to do to correct this and stop this behavior. Especially if I am not immediately at the table when a job finishes to hit the kill switch.

Check to see if you have $J jogging enabled (in Device Settings), though that shouldn’t matter for homing position.

Have you enabled a workspace offset? What does ‘Get Positions’ report back when you’re at the center origin?

$J Jogging is NOT enabled.

Get Position reports back X: 39.2 Y: 40.3 which is way off in the front left corner from where the 0,0 is in the far back right so how do I get this to change? I can’t seem to find where the workspace offset is set

Workspace offset is set in the controller itself. If you used it as a CNC recently and zero’d to a workpiece, you likely changed the workspace offset. Type $# in the console, and look at the values for G54.

You can read about what LightBurn expects for the workspace offsets here: https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md#common-grbl-setups

Basically, after homing, type G10 L2 P1 X-812 Y-812 to set zero in the front left. (those are negative values, the size of the workspace)

I did the $# and G54 is: [G54:-812.000,-812.000,0.000]

I re-homed the machine and typed in the G10 command string and it is still going all wonky.

Are you running in inches?

When you use the G10 command, it moves 0,0 to the front left corner. So what you said earlier about Get Positions returning the wrong value is probably incorrect.

With the workspace offset applied, 0,0 should be in the front-left, and 812,812 should be back-right, where your machine origin is.

LightBurn doesn’t like negative numbers for workspace coordinates. DSP controllers don’t even support them, and all the CNC work I ever did used positive workspace, so I was really surprised to find out that GBRL shipped with Shapeoko and X-Carve machines uses negative workspace.

I plan to support it, but there are a lot of places in LightBurn that assume negative numbers are an error, and I have to go rip all of that out. Then I have to buy an X-Carve so I have a way to test it easily.

Yes, running in inches. it all ran fine in version 0.9.07 and I just upgraded to 0.9.09 yesterday and that’s when it all went screwy.

I know a bunch of jogging code changed, but mm/inch shouldn’t make a difference there. Try running in mm mode - it’s possible that the machine is resorting positions in inches and we’re expecting mm, maybe? I might need to add code to set the units explicitly every time we ask for position.

I ended up switching back to CNC mode to do a cut I absolutely had to finish. while there, I made sure that I clicked on clear offsets. After my job was done, I loaded up Lightburn again, clicked on Home and the machine did home correctly. I then clicked on my use Laser Macro which includes:

G10 L2 P1 X-812 Y-812

From there I moved to a location on the worksurface, loaded up a simple dxf and positioned the laser directly over the center (origin). I clicked on Clear Origin and then Set Origin. I then jogged the laser off of the center spot and from there clicking on Go To Origin, instead if it moving back to the place I had just set, it goes zipping off into another world of it’s own still seeking that place in the front left corner.

Try doing the same thing in mm mode instead of inches - I suspect that’s the difference - I very rarely use inches, because all the hardware actually works in mm internally. I’ll have to be explicit about which unit mode it’s in when I query it. I am already when I send move commands, but I don’t set it to Inch or mm mode when I ask the controller where it is, and I think I need to.

changing this from inches to mm and going through the homing and running the macro I listed before had no effect at all and the system still wanted to travel off into the unknown when clicking on go to origin despite having clicked on clear origin and set origin which should have been at the current position. I also noticed that when I clicked on the set finish position, it kept telling me that the coordinates were outside of the work area. hmm… so I got to messing around with various things and jotting down notes and noticed that if the work area under Device settings where changed however so slight from the actual overall bed dimensions (in this case 812 x 812) then this would cause strange behavior as I have been experiencing. Even though the overall work area is 812x812, a person cannot change that to say 350x350 without the go to origin etc getting all skewed. So, I would recommend that somehow get the work area to be a fixed and unchangeable value from what the machine reports when homed. Once I made sure the work area was 812x812, it all started functioning correctly again.

The work area is supposed to be the area of your machine. If you change that, it confuses the code that checks to make sure everything in in bounds.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.