Unexpected Z axis movement

I just made something and the focus was way off. I thought I had just forgot to set the focus, but when I just now started a new one I made certain I set the focus (using auto focus from the “Focus Z” button in LB). Then when I checked Start, I was watching closely and I saw the bed of my laser raise up about .5 inches before it started scanning ! Then I remember that yesterday I was trying to get the multi pass option in LB to work with an adjustment in Z height for each pass.

LB did not seem to be able to control the Z once the job started so I when into the “Decide Setting” and turned on the “Enable Z axis” switch thinking that maybe that was preventing LB from controlling the Z between passes.

It did not fix the multi pass problem but I forgot to turn off the “Enable Z axis” switch. That seemed to cause the bed to move before it started cutting today. I have no idea why.

So I turned the switch back off and now everything is back to normal. Is this a known issue with Boss Ruida machines?

Ruida controllers do not have a command to perform a relative Z move during a cut (as far as I’m able to find). This means that if you enable Z control, you currently have to set the “Material (mm)” value on the main page to be the starting Z height for the job. I’m going to automate this shortly - as in, when you have Z enabled for Ruida devices, it will read the Z height of the machine when you start the job and run the cuts from that value.


So we should leave that switch in the off position.

… unless you’re trying to use the Z axis, yes.

The Z axis control in LightBurn is the equivalent of “Pen Mode” in RDWorks. The commands used are identical.

What is Pen Mode? First I have heard of that.

It’s quite literally for using a pen to mark surfaces (a way to use your laser as a plotter). You can even specify an offset between the pen and the beam point, and the amount to raise the bed for the pen to contact the surface, and the Z to return to when done. These are the functions that LightBurn uses to do Z moves during cutting.

1 Like

Is there a way to stop the pen mode behaviour?
I currently have grbl v1.1f on an Arduino and have noticed if you set your laser for engraving, it will move the head away and back again for literally every letter.
It is great to have the head move away completely after finishing.

You could disable the Z entirely, but I assume you want the Z to move, just not extra moves in between, correct?

Yep. Having the Z Axis ability to move down as you cut thicker items is a great feature.
I understand this is the normal behaviour and was hoping it could be disabled within the UI.


I’m planning to add an “optimize z moves” switch, but I didn’t want to make it the standard behavior, in case someone was using hold-downs that needed to be avoided / cleared.

Sounds good. It is great to see a dedicated group of engineers listening to the community and implementing brilliant features.
Will definitely purchase a license for this product.

BTW I think there is an issue with the feature to run a Homing Cycle at start-up in that it does not seem to work. Should I report that somewhere else?


I tried to fix the “home on startup” issue before, in release 0.9.00, and it ended up causing no end of other problems. I was previously looking for the “Grbl 0.xx [pres $ for help]” message, but if the controller is powered before LightBurn connects, it won’t always say that. I’ll try sending newlines until I get an ‘ok’ response and see if that works.

Cool. I only recently installed the trial version (4 days ago I think) so I believe I have the latest and have been really impressed in this product.

I am currently proto typing a custom made laser engraver with the view to building a decent sized cutter some time later this year.


This would be so awesome! I think the Ruida Z-height is confusing anyway, because my machine always reports Z as 4mm after auto focusing. But that’s just the amount of mm the bed moves downward after the auto-focus probe hits the material. It has nothing to do with the actual material thickness. Took me a while to figure that out; I would get unwanted Z-axis movements depending on how much the material thickness set in LB deviated from 4mm (such fun to try to understand what was happening, when cutting actual 4mm thick material didn’t result in Z-axis movement).